Cron on Local (BackupBuddy-related)


I’m trying to use BackupBuddy Development feature which pulls and pushes content from one site to another - something like staging - see here:

The local and the online site communicate with each other but I have the following error which seems to be related with the cron system on the local.

The problem is that I don’t know what to do.

Error: Error #9038: Loopback test error: cURL error 7: Failed to connect to translated.local port 443: Connection refused. URL: https://translated.local/wp-admin/admin-ajax.php?action=itbub_http_loop_back_test&serial=636o0qdz4fohv3p. If you need to contact your web host, tell them that when PHP tries to connect back to the site at the URL https://translated.local/wp-admin/admin-ajax.php?action=itbub_http_loop_back_test&serial=636o0qdz4fohv3p via curl (or other fallback connection method built into WordPress) that it gets the error cURL error 7: Failed to connect to translated.local port 443: Connection refused. This means that WordPress’ built-in simulated cron system cannot function properly, breaking some WordPress features & subsequently some plugins. There may be a problem with the server configuration (eg local DNS problems, mod_security, etc) preventing connections from working properly.

1 Like

Hi @ivo,

This will be resolved in Local 2.3.1 which is scheduled to be pre-released today :-).

Sorry for the trouble!

Good news. Thank you!

Alright, it’s here! See Local by Flywheel 2.3.1 (Pre-release)

I am still having the same problem. I just downloaded the pre-release but it didn’t change anything. I am unable to use the push-to option and I am unable to make a backup. Am I needed to do something besides just run the newer version?

Did it work for you after updating to the new version?


Make sure you restart the site(s) after updating to 2.3.1.

I did that and now it just times out. There must be something wrong with my installation or something. Everything is default settings. Oh well… I should have tested it before I did much work on the site, I guess.


Please try the following:

  1. Right-click on the site having trouble
  2. Go to “Open Site SSH”
  3. Run apt-get update && apt-get install -y ca-certificates
  4. Retry the BackupBuddy backup

I tried that with no success. Thanks for trying. I’ve got to move on though. I will do a manual site migration to get the site.

@clay did this get resolved. I’m having a similar issue. I have the two sites talking however whenever i try to get a pull or push i get a communication error from the plugin even though both sites say they are live. This is the error however when you go to the deployment tab in backup buddy it shows the site is up and when you do a test connection it says its worked. Any idea on how to resolve this?

Errors were encountered: Error #8001: Unable to decode json response. Verify remote site API URL []( , API key, and that the remote site has the API enabled in its wp-config.php by adding define( ‘BACKUPBUDDY_API_ENABLE’, true ); somewhere ABOVE the line “That’s all, stop editing!”. Return data: [Server response here]

I’m having the same issue! So frustrating for non-programmers. Im using Local version 2.2.4 and still the same issue. Please advise as I have to get my site migrated.

I also use SSL, but have no idea how to disable it on both sites to enable the use of BackupBuddy with Local.