Unable to provision site local

What issue or error are you experiencing?

When I try to create new site in local I have this error

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

System Details

  • Local Version: Last one version

  • Operating System (OS) and OS version: MacOS Sonoma 14.1.1

Hi @Simonebruzzi

Are you using the Apple Silicon install of Local? If so do you have Rosetta installed?

If not, can you share your Local Log here? There are some different ways to access and share Local Logs. For us to be able to troubleshoot thoroughly, please click the Download Local Logs button from the Support tab in Local. This will generate a zip archive that contains the Local log along with some other diagnostic information to help quickly zero in on any issues that Local is encountering.

local-logs.zip (5.3 KB)

Thank you so much

Hi @Simonebruzzi

Thank you for that! Were you able to confirm if you’re on the Apple Silicon version of Local? It looks like from the error the issue might be that you’re missing Rosetta which is required for this build.

You should be able to install it with this:

usr/sbin/softwareupdate --install-rosetta

I tried to delete e install another time to be sure to have installed Apple silicon version but nothing.
Where have I to write this usr/sbin/softwareupdate --install-rosetta ?

Thank u

You’ll need to open up a terminal window and run that command.

Open or quit Terminal on Mac - Apple Support.

i dont understand, why is rossetta needed it is a native apple silicon ARM app, not the intel version!!

Per our minimum requirements within the doc I shared above, Rosetta is currently still necessary for any Apple Silicon builds:

Rosetta 2 is required for Local’s Apple Silicon build due to the Nginx and MySQL Lighting Services compiled on the Intel architecture.

We plan to have a release out eventually that won’t need this, but for now it is still required.


thanks, is seems to the app needed administrative rights to access /etc/hosts

but know I know there is more to this.

BTW, ubuntu has multipass, a very lean way to setup an ubuntu container on linux, windows and Mac, this runs also native on apple arm64, maybe host the Nginx/MYSQL into that. you can mount the /Local Sites/ data to the correct folders.

have a look (multipass find) at the docker image and their use of multipass and there is also Minikube as example, but you can make your own image. just set it to unattended upgrade and its worriefree self updating.

having it containerised is also much more saver than installing it bare metal, especially when you use the live link tunnels.

On terminal the command failed, what path I have to write?

Can you share a screenshot of your terminal showing the command and the failure?


Someone can help me??

Hi @Simonebruzzi - try without the /usr/sbin

Open terminal and run softwareupdate --install-rosetta.

Other users have found this document helpful - How to Install Rosetta 2 on Apple Silicon Macs

1 Like


Now it works!!


Thank you for following up and letting us know @Simonebruzzi!

1 Like