I can't use shell: I get the error "Command not found"

I need to reset the administrator password. If I type the command “wp user list” (as explained here: Reset a WordPress admin password - Local) I get the error “Command not found”.

I am a beginner in using Terminal. I need to reset the administrator password but I put “Open site shell” and it opens the terminal at the starting point of my computer.

I have navigated to the site directory and the command doesn’t work either.

What am I doing wrong?

From already thank you very much!


System Details

  • Local Version: 8.1.0+6514

  • Operating System (OS) and OS version: macOS 14.2.1 (23C71)


Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)


Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @halones03ceno

Does everything else within Local work normally? Are you able to create a new, blank site? If you do that and access the terminal on a new site do the commands work there?

Please also share your Local Logs here if possible. There are some different ways to access and share Local Logs. For us to be able to troubleshoot thoroughly, please click the Download Local Logs button from the Support tab in Local. This will generate a zip archive that contains the Local log along with some other diagnostic information to help quickly zero in on any issues that Local is encountering.

Hello,

Thank you very much for your help!

Yes, everything else works correctly. I have several websites. But the problem with the console occurs on all websites.

Attached Download Local Logs

Thanks again!
local-logs.zip (36.7 KB)

Are you utilizing Apache?

If you stop all sites, and create a new blank site using NGINX does that work?

I have six sites running on Local, five with NGINX and only one with Apache.

Now, with all existing sites stopped, I have created a new site called “Test site” using Local and NGINX.

Then, I clicked on “open site shell” and tried the command, but it still doesn’t work


Thank you so much

Can you try running brew install wp-cli and see if that works to get things up and running?

I also found a previous post here where a use was getting a similar error: