I tried to fix this node/virtualbox error that a bunch of us are seeing with no luck. Please help!

my machine: windows 7 64 bit
Virus software: ESET endpoint antivirus (it’s big and bad and I have no control over it)

I’ve used localbyflywheel up to yesterday with no problems. Somehow between the latest update and perhaps updates to windows or virtualbox or other things I started seeing a bunch of errors. I searched here for help and took a bunch of steps that ultimately ended in me not being able to even launch a site or start a new site.

Here goes:

–A few days ago I noticed there was an error I was seeing when stopping one of my sites with a custom environment. It was saying windows couldn’t find node or a file in extra resources like others had described in other threads. The site was still working so I thought maybe after restarting my computer things would be ok. I still saw the error.

–Yesterday, I tried to create a new site with a custom environment and the error actually prevented the site from being created, so I came to the help forum to see if I could figure it out. Seeing other people dealing with similar issues, I tried to follow advice I had seen on a bunch of threads. I uninstalled everything and tried to reinstall local again.

–While trying to reinstall it basically said that it couldn’t find virtualbox, see above.

–Then when I dismissed the alert, another sad alert displayed, see above. Then the whole installation stopped.

–Based on another thread I saw, I decided to reinstall virtualbox myself (I vaguely remember my very first install of localbyflywheel did this for me, but I may be misremembering). When I opened virtual box, it showed that I had an inaccessible instance of localbyflywheel, see above.

–Hoping that the two would sort themselves out together, I went back to localbyflywheel to see if the presence of virtualbox would calm it down. It did, kind of and then it started alerting me again that it couldn’t find node or couldn’t create hosts and all kinds of stuff, see above.

–My sites are all reporting that they can’t find containers, the fixit thing doesn’t fix it see above.

–When I went back to virtualbox, it now has 2 instances of localbyflywheel, see above.

To make sure I wasn’t just insane or that my virus software wasn’t conspiring against me, I repeated all the reinstall stuff I said above as an administrator and it still had the same result.

I’m more technical than some of the folks here, but virtualbox/docker stuff is not yet in my wheelhouse. I have a feeling docker is really not happy with me from what I can see of the logs, but again, I’m not an expert here.

Here’s my log:

local-by-flywheel.log (59.8 KB)

Please please please, someone help me if you can.

Hey @tnaughton

Some of those files may have been quarantined during an update or install. Is there any way to temporarily disable ESET endpoint antivirus? Then try to reinstall Local?

Let us know if that works!

Hi Jake,

The engineer who does all of our security and hardware is out of the office right now, so it might be a few days before I can get back to you, but I will see if they’re ok with disabling this temporarily to try to figure out if the antivirus is quarantining files.


I was able to temporarily disable the anti-virus software. I got the same results. The path to node is correct. I also checked my anti-virus software’s quarantined file section and those files were not listed.

Please help.

Hey @tnaughton

I did come across this article, that looks like this can happen from time to time with Windows apps.

If you start at the part that says "2. Re-register Windows 10 Apps"

Can you let us know if that fixes it for you?

Hi @jkiley ,

Thanks for your response. Because I was on Win 7, it didn’t work for me. I made the choice to upgrade to win10 and start over and things seem to be working pretty well so far. Thanks again.