I tried to upload the zip pro theme to my local wp. Cannot access site at all now

Issue Summary

Tried to upload a pro theme onto my wp local site, duchess. i had been working on the free version for weeks without any issue. after i attempted to upload the pro version, i am receiving a receiving fatal error message since and cannot access it at all.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    It only happens on this site as far as i’m aware. i have another old site on local that won’t open either, but i’m not sure its the same problem.

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?


Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

I was in local working on my site, and went to “customize” and uploaded “ashe pro” theme and activated it. After that, i receive this error message. I cannot log in and work on my sites dash at all.

System Details

  • Which version of Local is being used?

  • What Operating System (OS) and OS version is being used?

    • For example: macOS Catalina or Windows 10 Professional

windows 10

  • Attach the Local Log. See this Help Doc for instructions on how to do so:

    • Retrieving Local’s Log
      Fatal error : Uncaught Error: Undefined constant “SECURE_AUTH_KEY” in C:\Users\inkii\Local Sites\duchess\app\public\wp-content\themes\ashe-pro-premium\freemius\includes\class-freemius.php:4034 Stack trace: #0 C:\Users\inkii\Local Sites\duchess\app\public\wp-content\themes\ashe-pro-premium\freemius\includes\class-freemius.php(3885): Freemius->get_anonymous_id(NULL) #1 C:\Users\inkii\Local Sites\duchess\app\public\wp-content\themes\ashe-pro-premium\freemius\includes\class-freemius.php(3937): Freemius->ping() #2 C:\Users\inkii\Local Sites\duchess\app\public\wp-content\themes\ashe-pro-premium\freemius\includes\class-freemius.php(4779): Freemius->has_api_connectivity() #3 C:\Users\inkii\Local Sites\duchess\app\public\wp-content\themes\ashe-pro-premium\freemius\start.php(522): Freemius->dynamic_init(Array) #4 C:\Users\inkii\Local Sites\duchess\app\public\wp-content\themes\ashe-pro-premium\functions.php(146): fs_dynamic_init(Array) #5 C:\Users\inkii\Local Sites\duchess\app\public\wp-content\themes\ashe-pro-premium\functions.php(179): ashe_freemius() #6 C:\Users\inkii\Local Sites\duchess\app\public\wp-settings.php(585): include(‘C:\Users\inkii\…’) #7 C:\Users\inkii\Local Sites\duchess\app\public\wp-config.php(93): require_once(‘C:\Users\inkii\…’) #8 C:\Users\inkii\Local Sites\duchess\app\public\wp-load.php(50): require_once(‘C:\Users\inkii\…’) #9 C:\Users\inkii\Local Sites\duchess\app\public\wp-blog-header.php(13): require_once(‘C:\Users\inkii\…’) #10 C:\Users\inkii\Local Sites\duchess\app\public\index.php(17): require(‘C:\Users\inkii\…’) #11 {main} thrown in C:\Users\inkii\Local Sites\duchess\app\public\wp-content\themes\ashe-pro-premium\freemius\includes\class-freemius.php on line 4034

There has been a critical error on this website.

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @Ingrid

Regarding the error Undefined constant “SECURE_AUTH_KEY”

There is a solution outlined in this thread:

We are aware of this issue and are looking for a long term fix as well as noted here:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.