Local Community

ImageMagick in Local 5.x

Hello.

How can I enable imagick php lib by default (or another way) in Local 5.x?

Thanks!

Hi @deryck,

To enable Imagick, you will need to install the Imagick extension from PECL.

If you’re on Windows, you’re in luck since you can simply select the DLL as a download option and then include that extension in the site’s php.ini.hbs file in conf/php.

On macOS and Linux, it requires compiling the extension using phpize. Also, if you’re on Catalina or newer, you will need to use the codesign tool on the resulting .so file otherwise it won’t be loaded.

With all of that said, we have immediate plans to re-add Imagick as an included extension since it’s something that WordPress looks for in its new Health Check.

4 Likes

Hi @clay thanks for answer me. I already installed the module in Catalina but when added extension to php.ini.hsb in conf/php I get an error. ImageMagick module not loaded.

I can wait is not urgent but as you already say, it is a WordPress requirement. Do you suggest I wait then?

I recommend waiting for now since it’s around the corner. Also, WordPress will use GD (which Local has) in place of Imagick/ImageMagick wherever possible.

Thanks @clay I’ll wait then.

:+1:

Hi @clay Any update on when ImageMagick will be included in Local 5? I just updated to 5.2.8 and it looks like it’s still missing. Thanks. And I love Local!

Hi Gabe,

Glad to hear it!

We haven’t added it to our PHP 5.6 and 7.3 builds quite yet, but it’s in PHP 7.4.1. You can select PHP 7.4.1 when creating a new site or importing a site.

If you need PHP 7.4.1 for an existing site, we recommend export and then re-importing it. Changing PHP versions for existing sites is coming soon! It’s in active development.

Got it, thanks. It looks like PHP 7.3.5 is still what’s used when going with “preferred”. I know I can select custom and go with 7.4.1, but just curious why 7.3.5 is still “preferred”.

1 Like

I just spent 2 days tearing my hair out trying to figure out why the “Image Size” dropdown wasn’t showing up for me in Image Blocks… even with a clean install of WordPress and no Plugins and the TwentyTwenty theme. Decided to just edit the HTML to put the image size I needed into my image SRC and that’s when I found out that image sizes are not even being generated! This is with the latest version of Local by Flywheel 5.6.6 and PHP 7.3.5. I tried a different thumbnail regeneration plugin and it told me that neither GD OR ImageMagick are installed. I don’t want to switch to PHP 7.4.1 because that breaks the Delicious Brains Migrate DB plugin. Erg.

Can anyone post step-by-step how to installed GD or ImageMagick in Catalina for Local by Flywheel? I’m losing my mind over here.

2 Likes

Ok I switched to PHP 7.4.1 and the re-gen plugin (by Alex Mills) is not longer showing a missing extension error on the bulk resize page but image sizes are still not being generated. I went to the media library and tried to resize just a single image and that says “ERROR: The current image editor cannot process this file type.”. It’s a JPEG! I even resaved for web in Photoshop just to make sure something wasn’t weird with the file. And tried a bunch of other JPEGs as well. Seriously after 2 days of this nonsense about about to just light my GD MacBook on FIRE. ARGH!

1 Like

Hi David,

I’m currently looking into this. Sorry for the trouble!

I just deleted Local from my Apps folder on my Mac and re-installed it. Not sure if that would make and difference of not. Sadly it did not. Maybe I need to re-install Catalina? Local just uses the PHP from Mac OS now right? That seems like a drastic measure thoughScreen Shot 2020-07-24 at 5.33.08 PM

I am seeing some regressions with our PHP binaries specifically with GD. I’m working through fixing that now.

As a workaround, you can switch to PHP 7.4.1 (if not already on it), then run the following in Terminal to install some dependencies that are required by ImageMagick:

brew install libpng freetype jpeg

If brew isn’t an available command, you can install it by following the instructions here: https://brew.sh/

No luck. Got a bunch of errors on the install

Error: Could not link: /usr/local/etc/bash_completion.d/brew

Error: Could not link: /usr/local/share/zsh/site-functions/_brew

Error: Could not link: /usr/local/share/man/man1/brew.1

Error: Could not link: /usr/local/share/doc/homebrew

Error: The `brew link` step did not complete successfully
The formula built, but is not symlinked into /usr/local
Could not symlink bin/libpng-config
Target /usr/local/bin/libpng-config

Error: Permission denied @ apply2files - /usr/local/lib/node_modules/npm/node_modules/.bin/node-gyp

Got it. Looks like there might be some permissions issues.

If you run brew doctor, it’ll provide some commands and info on what to do to resolve issues like those. Once you try what it recommends, you can run the install command that I provided above.

Sorry for the trouble here! We should have an update Monday or Tuesday that resolves these issues with GD/ImageMagick.

Thanks Clay. I visited the Doctor in but the patient is in bad shape. I think I’ll just wait for the update.

So this was an actual issue with the latest update of Local then? Not just some weird issue or corruption on my end? That’s actually reassuring because I thought it was just me. I was losing my mind.

Thanks and have a great weekend!

1 Like

I was also facing the same issue as uniondesign. Thank fully i come across this conversation.
It would be great if we can get the update soon as mentioned by clay.

Hi @clay. Any update on this?

I created a new site in Local 5.6.6+4375 (on a Mac) with the default settings. When I regenerate thumbnails, the plugin says:

This tool won’t be able to do anything because your server doesn’t support image editing which means that WordPress can’t create thumbnail images. Please ask your host to install the Imagick or GD PHP extensions.

Hello!

Thank you for this. I’m having the very same issue. I already switched to PHP 7.4.1. (WordPress no longer recomends to add Imagekit & GD extensions in site health) but I’m still not able to change the header image (I can add a background image though). I’m using Screenr theme (don’t know if it has something to do…). I’m also trying to configure php.ini.hbs file with Atom text editor, but I don’t know how to do it properly. Would appreciate help. Thanks!

Just posting to get updates from this thread. Having the same issue; for now my workaround will be to just run this process on the live site, but this is something that really should work out of the box, so to speak (and used to like a week ago, I think).