Images are no longer showing up on the website

What issue or error are you experiencing?

At first I thought the pictures were not showing up through live link but there are some of the pictures that aren’t showing up locally. When in Divi edit mode, all the pictures are there. I’ve tried turning off Static CSS File generation to no avail. The error in Chrome shows "Failed to load resource: <image.file> net::Err_ssl_Protocol_error.
All of this was working fine last week. I made no changes to site settings. There is no VPN on my workstation.

Thank you.


What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

Just viewing the site


System Details

  • Local Version:
    Version 8.1.0+6514
  • Operating System (OS) and OS version:
    Windows 10

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)
local-logs.zip (15.2 KB)


Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @se7enthsign

It might be that you have some mixed or insecure content. Protocol Error makes me think that maybe you need to do a Search and Replace to get everything from HTTP > HTTPS. Is your SSL trusted and the site showing secure in the browser? If it is then that would probably be your next step.

Once you’ve done that you could also try flushing cache, viewing in another browser or incognito window to make sure caching isn’t in the way.

I’ve not secured the local site at all during the build process. It was my understanding https on a local site would have lead to issues… if SSL was turned on somehow, I have no idea how.

Ah okay so in that case it might be the opposite and it’s trying to load securely over HTTPS. Are you able to see that in the console errors? Or do you see any other pathing issues?

The get statement is indeed trying to use https from the content vault. Is there a global setting causing this?

GET https://localhost:10004/wp-content/uploads/2023/

HTTPS isn’t supported in Localhost Router Mode. So you could try changing to Site Domains to see if that helps with any content loading.

Preferences>Advanced>Router Mode>Localhost

It fixes the image issue and broke one of my menu headings (but only on the home page) Not sure what that’s about…

Any errors in the console to indicate what might be going on?

I went and re-applyed the formatting and it fixed it. I’m still getting missing images in the Live link though…
Err_Cert_authority_Invalid

It sounds like your browser is still having issues with SSL. If you’re unable to trust the SSL and run S/Rs to make sure all content is secure then you could try moving the site to a Demo environment somewhere. For example Flywheel has free 14 day demos you could use:

I’ll give that a try. Thanx

1 Like