Import of wordpress site fails with Local 2.0.3

Previous full version of local was able to import full wordpress backup of website (channel zip archive) into local.
Version 2.0.3 does not complete the import. The database is completely ignored. T
In the past all that was required was a quick change to config.php to reflect the database name.
Unable to work off-line on active site because of this failure

I’m also having a problem importing a site to 2.03. I zipped together my .sql database and wp-contents folder, and dragged the ‘’ into 2.03. It hung on the ‘Creating site container’ step…

I let it run for about 6 hours, then quit Local and opened VirtualBox and reset the local-by-flywheel. I then relaunched Local and tried to start the site I’d been working on importing when it got hung up. My browser shows a Local Router Error. I’m guessing it’s a database issue based on this error in my log:

error: ‘Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (111)’
Check that mysqld is running and that the socket: ‘/var/run/mysqld/mysqld.sock’ exists!

Apologies if this isn’t the same problem as blinky is having, but it seemed similar to me.

Thanks for any help!

log file:
local-by-flywheel.log (49.6 KB)

I’m getting a similar issue. I import a site and during the import Local crashes and quits.

On re-opening Local, I click on the imported site (In the list in Red) and some warnings appear, followed by Local crashing and quitting again.


Error! Container is Missing
Warning! Missing Hosts entry

Hi @clay,

I know you’ve got your hands full, but any advice on my earlier message here?

I’ve also been monitoring this thread, and I tried to run the search and replace for the domain names with WP-CLI as you suggested, but I got an error message that the container is not running.

Would you mind having a look at my log file posted earlier when you have time?



I had the same problem. Local wouldn’t recognise that i had a DB in the folder i uploaded.
I deleted and re installed local and it seemed to work fine.

Sorry if you have already tried this, but it’s worth a try.


Alex!! Thank you so much! Simply uninstalling and reinstalling 2.03 worked like a charm! Thank you! Finally an entire week of trying to get Local working has a happy outcome!

Thanks again!!

Unfortunately this didn’t work for me. I had to go the long way and manually create the tables using the sql procedures present in the backup archive. Local should have done this for me as part of the migration plus the changes to config.php and the options table.

Hi Blinky,

Yea it definitely should have created them all for you including the config file. I hope that didn’t take too long!

I have actually recently just found that if i download a database through phpmyadmin it doesn’t actually download the database properly which will always mean that local won’t be able to pick it up.

The only effective way to to download your database is over SSH. ( I am new to SSH but it is actually very easy, especially if you are just downloading your db.) Speak to your hosting provider for detailed instructions on how to achieve this.

In my experience so far, i would always try and get local to work through the import new site feature as doing it manually does seem to lead to conflicts.

Hope that helps