Import to Local - URL redirect issue

I’ve just begun using Local and have developed a couple sites. Switched from Mamp. Works very well.

Now I’ve tried to import a live site and have some issue. I’ve been reading a few threads a managed to get close to good. But I’m not there. Hopefully I can get some help here.

I’ve zipped the live site with Duplicator.
Drag and dropped into Local - Failed "500 Internal Server Error"
Made a new zip from the duplicator package with only the sql-file and the wp-content directory.
Drag and dropped into Local again. - Works. Almost…

Now there is at least one little issue. The home url is redirected to a url which can not be found. I can’t find out where the redirection is. (It’s not in the wp-option table)

So the live site was a demo site in a sub-directory, like this:

In Local it’s imported like this:


All pages works fine except for the home page which redirects (and returns a 404) to:


Am I doing something wrong when importing? Happy for any help! Thanks!

Hi @dropshot,

Sorry for the trouble with importing!

What version of Local are you importing the site with? There were some issues in Local 2.1.2 where .htaccess files would become mangled after importing.

That has since been fixed in 2.2.1.

Hi @clay,

Thanks for your reply!

No problem, I think we will figure it out.

Yes I’m on 2.1.2. And I did read a thread about that. I tried two things:

  1. Reset the .htaccess file. This solved the 500 Internal Server Problem on my first try, but not the home-redirect.
  2. On my second try I didn’t even include the .htaccess file in my import.

You don’t think that the subfolder that I exported it from should cause any problems? (It never did when importing with Duplicator to Mamp)

I would check the wp-config.php file for WP_HOME and WP_SITEURL settings. See

Another thing that may be worth a try is flushing the permalinks. See