Importing from Local 3.3 without a proper export file

Hello everyone,

I have both the legacy Local by Flywheel 3.3 and current Local 5.6 apps running on macOS 10.15.6. I still have a couple of sites that were created in Local 3 that I need to work on.

Unfortunately, I have become unable to run sites from Local 3. (This may be due to a MacOS update, but that’s just a guess.) I get the error “Regenerating Machine Certificates. Local detected invalid Docker Machine TLS certificates and is fixing them now.” This message just repeats continually.

So I’ve tried bringing the sites into Local 5, but am struggling. I tried spinning up a new site and then using Adminer to import the various files located in the legacy app/sql directory, but encountered errors. The errors are all variations on: “Invalid default value for ‘comment_date’”.

Google/Stackoverflow suggests the problem involves strict mode and no_zero_date. I’m blocked by not being able to find the MySQL ini file, and not even sure that’s the solution.

Any tips on how to either a) getting Local 3.3 running just enough to properly export the sites; or b) overcoming the MySQL errors?


Hey, y’all, nevermind-- I found a workaround. I was able to import the SQL files into an instance on WP Engine, pull down a backup, and import that into Local 5. A few extra steps, but I’m happy to have it working.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.