Local Community

Impossible to edit hosts file and use 'Site domains' router mode

On Windows 10 I need to use ‘Site domains’ routermode, but I’m not allowed because I get the error message:

Uh-oh! Could not update hosts file
Local ran into an EPERM error when trying to update the hosts file
Please ensure the hosts file is not set to read-only and/or locked by an anti-virus

I have no anti-virus, I deactivated Windows Security, the file hosts is not set as read-only, I tried running the notepad as an administrator to edit the hosts file myself but I get an error message saying I need administrator privileges! I don’t understand what I need to do to edit the hosts file…

I could not find anyone who solved this issue on this forum.

This is a very interesting piece of information! If notepad, running as administrator, can’t edit the hosts file, then there’s not way that Local can!

I’ve never encountered this situation before, but doing a google search for this string:

can't edit hosts file even as administrator

gave me this interesting piece of info that you might try:

In any event, this is likely an issue with this specific machine, and in order to get Local to use the “Site Domains” option, you’ll need to zero in on exactly why the hosts file can’t be edited!