Local Community

Installation Windows - Local 5.2.7 won't open but 5.2.6 does

This isn’t the first time I encountered this problem with updates. The 3.x versions of Local had issues often as well, might be Windows specific.
After the update the program simply won’t start anymore.
It won’t even show up in Task Manager.
No errors, notifications of any kind. Re-installing doesn’t help either.
This often results in me needing to re-add all sites again.

Any ideas are welcome!

Note: Issue is with the 5.2.7 installation file. 5.2.6 worked fine.

Hi @keraweb,

So sorry for the trouble! If you downgrade to 5.2.6 (it’s safe to run the installer again, just don’t uninstall), will Local open again?

Same problem here on Windows 10 with 5.2.7.

Reinstalling 5.2.6 worked.

If you downgrade to 5.2.6 (it’s safe to run the installer again, just don’t uninstall), will Local open again?

Yep that works fine, running 5.2.6 at this moment.
I’m only wondering why this is happening once in a while with an update. Not sure what versions but this is the 4th time so far (the other times was with v3.x).

Hi all,

Thanks for the details.

We’re having a tough time replicating this issue on our end have tried various things like disabling networking, etc.

Is there any way you all can try installing and opening Local 5.2.7 and then immediately provide the local-lightning.log file? Considering Local isn’t opening, you will need to browse to it manually. Note the “Log file location” for Windows here: How do I retrieve Local's log file?

Once you do that, feel free to downgrade again to 5.2.6 so your workflow isn’t interrupted for too long!

I updated Local this morning around 10:45 CST. Nothing shows up in the local-lightning.log file after that, even after trying to load it up multiple times. The end of the file is the killing processes while shutting it down when updating:

    {"thread":"main","class":"Process","process":"nginx","pid":8724,"level":"info","message":"Killing process","timestamp":"2020-03-20T15:46:37.972Z"}
    {"thread":"main","class":"Process","process":"mailhog","pid":24064,"level":"info","message":"Killing process","timestamp":"2020-03-20T15:46:37.986Z"}
    {"thread":"main","class":"Process","process":"phpCgi","pid":29780,"level":"info","message":"Killing process","timestamp":"2020-03-20T15:46:38.001Z"}
    {"thread":"main","class":"Process","process":"phpCgi","pid":14252,"level":"info","message":"Killing process","timestamp":"2020-03-20T15:46:38.015Z"}
    {"thread":"main","class":"Process","process":"mysql","pid":26576,"level":"info","message":"Killing process","timestamp":"2020-03-20T15:46:38.028Z"}
    {"thread":"main","class":"Process","process":"nginx","pid":21256,"level":"info","message":"Killing process","timestamp":"2020-03-20T15:46:38.040Z"}

Everything before that is typical. I installed a new site a few minutes before I tried updating, and there are about 10 messages that correspond with it. I know it’s not much, but I hope it helps!

Rolling back to 5.2.6…

Got it, thanks for the details! We’re actively digging into this.

This thread appears to be a duplicate of Local not opening on Windows. Please direct any replies there!