Installing Local by Flywheel on mac

I am trying to install local flywheel on a mac (macOS High Sierra / Version 10.13.2) and it says to go to the system preferences > Security & Privacy > General and allow the extension from Oracle America.inc,
but I cannot find that option, how can I solve the problem?

Thanks in advance!

Hi @Sara1,

Sorry for the trouble!

Please try the following:

  1. Open up Terminal
  2. Run sudo /Library/Application\ Support/VirtualBox/LaunchDaemons/VirtualBoxStartup.sh restart … Note, you will be prompted for your admin password.
  3. Check Preferences » Security & Privacy » General for the approval button and click it if it’s there
  4. Re-launch Local

Hi Clay

It worked and was able to install the program.

Thank you

1 Like

I tried terminal command but I get message:

sudo /Library/Application\ Support/VirtualBox/LaunchDaemons/VirtualBoxStartup.sh restart

Loading VBoxDrv.kext
/Library/Application Support/VirtualBox/VBoxDrv.kext failed to load - (libkern/kext) system policy prevents loading; check the system/kernel logs for errors or try kextutil(8).
Error: Failed to load /Library/Application Support/VirtualBox/VBoxDrv.kext
Loading VBoxUSB.kext
/Library/Application Support/VirtualBox/VBoxUSB.kext failed to load - (libkern/kext) system policy prevents loading; check the system/kernel logs for errors or try kextutil(8).
Error: Failed to load /Library/Application Support/VirtualBox/VBoxUSB.kext
Loading VBoxNetFlt.kext
/Library/Application Support/VirtualBox/VBoxNetFlt.kext failed to load - (libkern/kext) system policy prevents loading; check the system/kernel logs for errors or try kextutil(8).
Error: Failed to load /Library/Application Support/VirtualBox/VBoxNetFlt.kext
Loading VBoxNetAdp.kext
/Library/Application Support/VirtualBox/VBoxNetAdp.kext failed to load - (libkern/kext) system policy prevents loading; check the system/kernel logs for errors or try kextutil(8).
Error: Failed to load /Library/Application Support/VirtualBox/VBoxNetAdp.kext
(kernel) Kext org.virtualbox.kext.VBoxNetAdp not found for unload request.
Failed to unload org.virtualbox.kext.VBoxNetAdp - (libkern/kext) not found.
(kernel) Kext org.virtualbox.kext.VBoxNetFlt not found for unload request.
Failed to unload org.virtualbox.kext.VBoxNetFlt - (libkern/kext) not found.
(kernel) Kext org.virtualbox.kext.VBoxUSB not found for unload request.
Failed to unload org.virtualbox.kext.VBoxUSB - (libkern/kext) not found.
(kernel) Kext org.virtualbox.kext.VBoxDrv not found for unload request.
Failed to unload org.virtualbox.kext.VBoxDrv - (libkern/kext) not found.
Fatal error: VirtualBox

some help???

@erikdenice,

Thanks for the output of that command.

Even though you’re getting the error(s), do you see an “Allow” button under Preferences » Security & Privacy » General after running the command?

Hey there,

Same problem on macOS Mojave 10.14. I’ve tried the command but it doesn’t pop the ‘allow’ button.

Should I try a different command?

Thanks!

JM

Hmm. Is there any output in Terminal after running sudo /Library/Application\ Support/VirtualBox/LaunchDaemons/VirtualBoxStartup.sh restart ?

Hello,

No I don’t get a message. In the terminal it show the key image. Because of the protection I suspect… But I don’t see anything in the system settings.

Gotcha. Once the key appears, type in your password that you use to login to your Mac and then press enter.

Allmost I suppose :slight_smile:

When I do that I get this:

Loading VBoxDrv.kext

/Library/Application Support/VirtualBox/VBoxDrv.kext failed to load - (libkern/kext) system policy prevents loading; check the system/kernel logs for errors or try kextutil(8).

Error: Failed to load /Library/Application Support/VirtualBox/VBoxDrv.kext

Loading VBoxUSB.kext

/Library/Application Support/VirtualBox/VBoxUSB.kext failed to load - (libkern/kext) system policy prevents loading; check the system/kernel logs for errors or try kextutil(8).

Error: Failed to load /Library/Application Support/VirtualBox/VBoxUSB.kext

Loading VBoxNetFlt.kext

/Library/Application Support/VirtualBox/VBoxNetFlt.kext failed to load - (libkern/kext) system policy prevents loading; check the system/kernel logs for errors or try kextutil(8).

Error: Failed to load /Library/Application Support/VirtualBox/VBoxNetFlt.kext

Loading VBoxNetAdp.kext

/Library/Application Support/VirtualBox/VBoxNetAdp.kext failed to load - (libkern/kext) system policy prevents loading; check the system/kernel logs for errors or try kextutil(8).

Error: Failed to load /Library/Application Support/VirtualBox/VBoxNetAdp.kext

(kernel) Kext org.virtualbox.kext.VBoxNetAdp not found for unload request.

Failed to unload org.virtualbox.kext.VBoxNetAdp - (libkern/kext) not found.

(kernel) Kext org.virtualbox.kext.VBoxNetFlt not found for unload request.

Failed to unload org.virtualbox.kext.VBoxNetFlt - (libkern/kext) not found.

(kernel) Kext org.virtualbox.kext.VBoxUSB not found for unload request.

Failed to unload org.virtualbox.kext.VBoxUSB - (libkern/kext) not found.

(kernel) Kext org.virtualbox.kext.VBoxDrv not found for unload request.

Failed to unload org.virtualbox.kext.VBoxDrv - (libkern/kext) not found.

Fatal error: VirtualBox

Awesome, thanks for that! Is your Mac on a corporate policy or is it a personal computer of yours?

Now that the command was run, do you see the “Allow” button under Preferences » Security & Privacy » General?

This is a personal computer and not on corporate policy.

No, the ‘allow’ button doesn’t appear. Should I turn something on / off. Or does it require a certain order in the steps?

Thanks for your patience.

I’m also getting the same issue. Mojave.

Also used the Terminal code, and received got the following error:

Loading VBoxDrv.kext

/Library/Application Support/VirtualBox/VBoxDrv.kext failed to load - (libkern/kext) system policy prevents loading; check the system/kernel logs for errors or try kextutil(8).

Error: Failed to load /Library/Application Support/VirtualBox/VBoxDrv.kext

Loading VBoxUSB.kext

/Library/Application Support/VirtualBox/VBoxUSB.kext failed to load - (libkern/kext) system policy prevents loading; check the system/kernel logs for errors or try kextutil(8).

Error: Failed to load /Library/Application Support/VirtualBox/VBoxUSB.kext

Loading VBoxNetFlt.kext

/Library/Application Support/VirtualBox/VBoxNetFlt.kext failed to load - (libkern/kext) system policy prevents loading; check the system/kernel logs for errors or try kextutil(8).

Error: Failed to load /Library/Application Support/VirtualBox/VBoxNetFlt.kext

Loading VBoxNetAdp.kext

/Library/Application Support/VirtualBox/VBoxNetAdp.kext failed to load - (libkern/kext) system policy prevents loading; check the system/kernel logs for errors or try kextutil(8).

Error: Failed to load /Library/Application Support/VirtualBox/VBoxNetAdp.kext

(kernel) Kext org.virtualbox.kext.VBoxNetAdp not found for unload request.

Failed to unload org.virtualbox.kext.VBoxNetAdp - (libkern/kext) not found.

(kernel) Kext org.virtualbox.kext.VBoxNetFlt not found for unload request.

Failed to unload org.virtualbox.kext.VBoxNetFlt - (libkern/kext) not found.

(kernel) Kext org.virtualbox.kext.VBoxUSB not found for unload request.

Failed to unload org.virtualbox.kext.VBoxUSB - (libkern/kext) not found.

(kernel) Kext org.virtualbox.kext.VBoxDrv not found for unload request.

Failed to unload org.virtualbox.kext.VBoxDrv - (libkern/kext) not found.

Fatal error: VirtualBox
  • Allow button appears in Privacy preferences but clicking on it doesn’t do anything. I even tried clicking on it and leaving it alone for a half hour.

  • Should the app be launched from the Applications folder? Does it’s launch location matter?

Solved! It seems High Sierra+ added new security measures that prevent the Allow button from being pressed via remote desktops, but also for some reason was blocking my mouse/mousepad from doing so as well.

The work-around is to enable Full-Access to keyboards and navigate via tab key. Here’s the article I found to do it:

https://discussions.apple.com/docs/DOC-13013