Issues with Sonoma?

Opening sites just display “It works!” and “There is a port conflict…” message in the app. This has only happened since I ran the upgrade, yesterday.

System Details

Version 8.1.0+6514


If you create a new, blank site in Local can you access that okay? If you can, then you may want to try reimporting any site that is having problems. The steps would look like this:

  • Locate the site files on your machine, and save a copy of them to your desktop. If you click Go to Site Folder under your site name it should take you right to where they are located.
  • Once you have those copied, completely delete the site from Local
  • Restart Local/your machine
  • Reimport the site back into Local. You can refer here on how to Restore from only Local site files

Thank you.

Same result with a brand new site:

If you change your Router Mode to Localhost are you able to proceed?

Preferences>Advanced>Router Mode>Localhost

Yes, works with localhost.

Glad to hear it @curiousways! Usually, if it works in Localhost but not in Site Domains that means something is conflicting as noted by the Port Conflict message. You can continue working in Localhost mode as long as that meets your needs. The only drawbacks are it only utilizes HTTP protocol and you can’t enable Live Links.

If you want to drill down further into the Port Conflicts we have an article here with some more troubleshooting steps:

Thanks, I have been digging into that but without finding out what’s causing the conflict, usually I’m alternating between Laravel Valet sites and Local sites, and it’s easy to valet stop, and start the Local app, however the “It works!” message is a new one, for which I’ve not found a solution (hence why I thought this may be due to a recent OS update)

I just did a Google search for the It Works! message because it’s not something I’ve come across myself. it seems like it might be a problem with Apache. Is that the server type you’re using?

Yes i’ve also seen this, some sites within my Local app use Apache, others Nginx. If I flip a problematic (“It works!”) ite between both, restart, etc, no difference.

Interesting - Well for now I’m glad Localhost is working as an alternative. If you get to where that isn’t meeting your needs you could try copying your sites and then doing a full uninstall/reinstall.

OK so after more investigation, the port conflict is when the default MacOS Apache is running. When it’s stopped sudo apachectl stop then Local sites (running nginx) will work as expected, in domain name mode, however, the SSLs fail.

I also removed the Apache install I had via Homebrew.

The new MacOS has lots of new notifications about running background processes, and perhaps a different way to manage them in a UI, wondering if this has anything connection to the issues.

We have some documentation around SSL below that may be worth checking to see if something is amiss there.

Thanks, i’ve been through those many times in the past and I’m happy with how I’ve got SSL working with Local, again this seems like something with the new OS.

I appreciate I have a fix (use localhost) and I’m happy with that. However, what’s your take on the MacOS version of Apache being stopped, that then enables Local to work again. I’m assuming Local has it’s own containerised version of Apache that boots up when you start the app?

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.