Router Mode, domain conflict in Local 5

I Just installed Local 5.2.3. And thanks for this fantastic piece of software!
I already have Local By Flywheel installed. I tried to Export and Import a site to Local. I get a message that there is a port conflict with the site’s domain. I read about it here:, but it doesn’t suggest anything to solve the issue or what might be causing this. I am on Macbook Pro 10.15.3 Catalina.
I’d rather use domains than localhost, so I am hoping that it can be fixed. Is there something that I could do to fix it or is it something that Local will be fixing in next version?

1 Like

Looks like I have a similar thing. Cross-posting for reference: Upgrade Error: WordPress URL settings don't match error and Laravel Valet Conflict

I was getting “There is a port conflict with this sites domain”. It was driving me nuts.

  1. I deleted my old 3.x install
  2. Removed homebrew php and apache
  3. Restarted a bunch while trying everything I could think of.

It ended up being the default Mac server running and keeping Local from accessing the ports. Used the below command in terminal to stop the Mac web server:

sudo apachectl stop

It will prompt you for your admin password. I am not sure if this will be an issue with every restart, but at least it works. I will take this hassle for getting rid of Virtual Box. So far it runs really great and fast.

EDIT: so far that stayed consistent with restarts.

1 Like

Thank you. Was tearing out my hair. Now I can use SSL with Local!

For someone who finds this thread. You don’t need to uninstall old 3.x install.
sudo apachectl stop
command worked for my macbook. TY Jake.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.