Just installed LocalWP and need PDO extensiuon

What issue or error are you experiencing?

I’ve installed PhastPress plugin and am getting a error " Sorry, PhastPress requires a PHP extension that is not installed."

Searching the forum, many posts mention the requirement for PDO, but I cant find an answer.

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

System Details

  • Local Version:

  • Operating System (OS) and OS version:
    Windows 11

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

Can’t find logs

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Just run phpinfo and it seems to be there. I’m stumped as to why this is failing though

Hi @peteharrison! What PHP version is your site using? This should work normally with 8.2 I believe.

I’ve just tried PHP 8.2.8 but still get the error.

After changing the PHP version can you stop the site, Quit Local and then open it back up and check again?

Nope, still the same error. PHPInfo shows PDO and SQLite but still showing the error.

So I tried adding “extension=php_pdo_sqlite.dll” and “extension=php_sqlite3.dll” to the php.ini.hbs file, but nothing worked. Maybe it needs compiling or something, I don’t know anything about HandleBars


I just created a test site in my Local app with the same configuration and installed Phastpress but it sets up fine without any errors. Maybe the next thing to try would be completely uninstalling/deleting the plugin from the site and then reinstalling it? Or you could try spinning up a new site and seeing if it works there.

Give it a mo and I’ll try

What OS are you using? Removed it and re-installed but the same.


Think I solved it, I used Apache rather than the default NGINX and it worked.

Not sure why, but you pointed me to look at the right things. Thanks again


Glad to hear you got it working @peteharrison! Thank you for letting us know what resolved it.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.