Unable to start site. MySQLAdmin cannot connect

What issue or error are you experiencing?

Hello:

I have installed the latest version of localwp. When I attempt to create a new site, I get an error about MySQL.

I am running the application on Release Linux Mint 21.3 Virginia 64-bit.

Am I expected to install MySQL and PHP separately?

Best,
Richard


What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc


System Details

  • Local Version:

  • Operating System (OS) and OS version:


Local Logs

local-logs.zip (25.3 KB)

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)


Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @richardkrone

Am I expected to install MySQL and PHP separately?

No that shouldn’t be necessary. Is this your first time using Local?

Can you share your full Local Log here? There are some different ways to access and share Local Logs. For us to be able to troubleshoot thoroughly, please click the Download Local Logs button from the Support tab in Local. This will generate a zip archive that contains the Local log along with some other diagnostic information to help quickly zero in on any issues that Local is encountering.

I have just added the local-logs.zip to the original post.

I used this application on a prior version of Linux Mint. I recently did a fresh installation of the Mint OS on the same hardware. I did a fresh installation of localwp via the official DEB file. No errors on installation.

I have also tried switching the router settings without any success.

Thanks for responding.

Best,
RIchard

To check are you running other developer applications simultaneously? Apps like MAMP, XAMPP, or Docker for example.

No. I was hoping that this localwp app would handle it all.

If you change your Router Mode to Localhost are you able to proceed?

Preferences>Advanced>Router Mode>Localhost

Hello Nick-B:

I looked in Preferences>Advanced>Router Mode and saw that it was already set to localhost.

I figured no harm done and tried the other option of Site Domains. Still no luck.

Best,
Richard

Yep I see that in your original error now. I was looking through your log and noticed these which seemed like a port conflict, but so far we haven’t been able to root it out with any of the usual checks:

{"class":"Process","level":"warn","message":"2024-01-26T15:02:15.951064Z 0 [ERROR] [MY-010262] [Server] Can't start server: Bind on TCP/IP port: Cannot assign requested address","process":"mysql","thread":"main","timestamp":"2024-01-26T15:02:15.960Z"}

Yes, I noticed that. I am unsure why.

It worked on the previous version of Linux Mint. The fresh installation of the newest version of Mint appears to have changed something.

This morning there were some updates via APT. I looked them over and found nothing related. I ran the updates, rebooted, and tried the local app again. Same results of an error as before.

I see that while LocalWP is requesting mysql-8.0.16+6 the version that appears to be default, via apt, to Linux Mint 21.3 is 8.0.35-0ubuntu0.22.04.1.

Does this make a difference?

I just added a site by changing the MySQL version from 8.0.16+6 to 5.7.28!

So, apparently it is having issues with the newer version of MySQL.

So, changing the MySQL version does allow LocalWP to provision a site. That site does not work. I get a 502 error at this point using the Site Domains option.

If I try it with localhost I get “Unable to connect”


error.log (6.4 KB)

I also have switched from nginx to Apache. Now it works!

So, nginx and mysql-8.0.16+6 do not appear to work out of the box with Linux Mint 21.3.

Hello: I am going to assume that this issue is unresolvable.

I am going to re-image my workstation at this time anyway.

Please close this ticket. Thank you.

If you look to revisit this in the future, after some digging what we noticed is that there seems to be a port conflict between MySQL and Nginx.

To troubleshoot this you could first try restarting their computer and then check your sites.json to see what it shows for Ports. Then if you edit or kill either the MySQL or Nginx does the issue go away? That might help narrow things down.

Hello:

I actually have re-imaged my machine in an effort to get it to work.

The reimage seems to be a success. Though it may break again when I start to install the basic packages from the software repo.

Best,
Richard

Thank you for the follow up! Keep us posted if we can help any further along the way.