LBF fails to prompt admin credentials

Local fails to prompt the admin credentials.

  • when I start the app
  • when I click on “Trust” for SSL feature
  • when I try to add a new site
  • update hosts

not much in logs:

Feb 22, 2018, 10:10 PM GMT-5 - info: [main/waitForMySQL] Querying MySQL
Feb 22, 2018, 10:10 PM GMT-5 - info: [main/hosts-helper] hostsHelper: Updating hosts with false hisports.local www.hisports.local reflector.local www.reflector.local
Feb 22, 2018, 10:11 PM GMT-5 - error: [main/hosts-helper] Could not update hosts. 
{ stdout: undefined,
  stderr: undefined,
  error: {},
  exitCode: undefined }

I see this :

but nothing happen next…

I occasionally use Local on my home laptop, OSX 10.12.6, so I can’t remember since when I have this issue.

Hi @sariha,

I appreciate the log snippet! Unfortunately, not much is showing in it.

Is there anything that you can think of that would be interfering with the admin prompt such as anti-virus, not running Local on an administrative account, etc?

Hi @clay,
thanks for the quick answer,
I have no anti-virus (I deactivated little snitch) and no other user, I’m using the only admin user.

My MacBook is running with Sierra.

I tried to reset my home folder permissions, no luck with this one,
I also tried to delete the virtual machine in Vbox, and after re-import website,
still no credential prompt…

I don’t know what to do at this point.

I ended by update to High Sierra…
solved the issue !

Hi @sariha,

Glad to hear you were able to sort it out by upgrading to High Sierra!