Live link images missing, using Astra with the default Block editor

Issue Summary

I made a website with Astra and did not use the Elementor editor, but the images are not showing up in the live link.

I tried a supposed fix in Live link not showing all images - #4 by atom_hubert
I tried replacing the Current media URL from http://[my site].local/wp-content/uploads/2022/10/image.jpg to wp-content/uploads/2022/10/image.jpg
/wp-content/uploads/2022/10/image.jpg to wp-content/uploads/2022/10/image.jpg

This fixed the image blocks, but this was not possible for the following background image in a container:

because I can’t choose to replace the image’s current media URL.

How do I fix this issue?

System Details

  • Which version of Local is being used?
    I am using 6.4.3+6116

  • What Operating System (OS) and OS version is being used?
    Ubuntu 22.04.1 LTS

  • Attach the Local Log (4.3 KB)

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @tristanyeom! Does regenerating Astra’s CSS have any impact? The steps should be something like: Appearance > Astra Options > then over to the right you will see “CSS File Generation” > Click the “Refresh” button.

Hi! Thank you for your reply. Please correct me if I’m wrong, but I think that option requires Astra Pro. Is there a solution if I’m using a free version of Astra?

Hi @tristanyeom, you’re correct that would be for the PRO version.

Going another direction here, could you give the below steps a try?

  • Run the following WP-CLI command
    wp search-replace 'SITEURL' 'LOCALURL' --skip-columns=guid

  • Replace SITEURL with your production URL like

  • Replace LOCALURL is your Local Site URL like http://mysite.local

  • Trust Local’s SSL certificate

  • Disable certain types of plugins: caching, security, force HTTPS/SSL

Hi @Nick-B,

Thank you for coming up with possible solutions, but I am still having trouble. However, I might not have understood your recommendations.

Here’s what I’ve tried:

  • That command resulted in 0 replacements, and I think it may be because I don’t have a production URL. to replace SITEURL, I tried using the Live Link URL generated by Local: the one. for example: I did
    wp search-replace ‘’ ‘http://example.local/’ --skip-columns=guid
    I tried variations of the URLs, removing https://, switching the ’ to ", etc.

  • I trusted the SSL in the overview menu

  • The only plugins that were installed are:

  • Oh, and something I just did rogue was I looked at wp help and saw that there was a wp cache flush command. I tried it, and I don’t see a difference. Bummer.

I don’t have a production URL. I’m trying to share the Live Link URL generated by Local.
Also, I’m not too savvy with computers and I just installed Ubuntu to challenge myself. Trying to figure out how to even get any WP-CLI commands to run was fun, so thank you!

Hi @tristanyeom - thank you for the follow up!

As a workaround, if you are needing to share the site with someone, the quickest route would be to deploy the site somewhere. Using Connect to Flywheel is pretty easy, and they allow a demo site to be spun up which means no cost to you upfront. Flywheel Demo Instructions

If you push it to a Flywheel demo site we could also try pulling it down on our end to see if we can replicate the issue.

For further troubleshooting would you be able to share an updated Local Log here? Retrieving Local’s Log File

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.