Local Community

Live link not working, why?

Why is live link not working? thank you

Hey Vladimir! How’re you doin?

So, it depends a lot on your network setup, it may be a lot of things…
But for starters, did you wait some time to see if it works? Upon starting a site, and creating a live link, sometimes there is a brief moment that Local is setting things up, so it can take some minutes to get it going.

Also, can you post your Local log so the community can help you further? If you need help with that:

Im doing awesome, thanks. I notice when I changed setting to “preferred” it works buy not when I use “custom” settings

Local’s Log
local-by-flywheel.log (276.1 KB)

First, looks like your SQL Dump backup is not working… Check if the folder /Local Sites/yoursite/conf/sql exists, and if there’s something in it… Because of this line on the log:

Error copying MySQL config { message:
‘ENOENT: no such file or directory, lstat ‘C:/Users/*redacted*/Local Sites/*redacted*/conf/mysql/’’

Another thing, is if there is any ngrok logs… You can check /Local Sites/yoursite/logs folder and see if there is any folder called “ngrok”.
ngrok is the software that generates the Live Link feature, that way we can see if theres any error there…

I fixed it by deleting and creating a new site. thank you

1 Like

its not working again. When I use thrive themes builder/templates it show this:

when i dont use the builder/template it does show the site

Check your .htaccess if there is anything out of the ordinary.
There is something that is creating a redirect loop

I wish I new how to do that, I guess i will not be using the software. I thought the software was made to make web building more simple. I appreciate you trying to help :slight_smile:

Hey Vladimir, I’m sorry you see that way, but indeed there are still some technical matters that may be tackled when using Local. Still, the app brings a great deal of simplicity compared to the real deal, configuring local environments by hand or using VMs… If you think this requires technical knowledge, let along the complete development process.

To get into this world of developing and using local environments you really will have to dig even a little into the technical side of it. If you are interested, you can read some articles about redirect loops and Apache .htaccess, which controls the access to your files when browsing a website.
Or you can use systems made to oversimplify (which means you lose a lot of control of your website, and they tend to be paid) the development and creation of sites, like Wordpress itself.

it was Thrive Themes (not using anymore), it works now. thank you

Glad to know! Maybe someone with the same problem can see this topic and know whats wrong as well ;D

Hi Vladimir.

I know this is an old thread but I’m experiencing the same problem you had and I’m also using Thrive Themes. Did you ever manage to resolve this and go back to using Thrive ?

Thanks
Luana :slight_smile:

Im currently having the same issue - ive tried everything with no luck. This is the screen i get when i click live link (and im using the Foodica theme)

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.