Live Link only working for 1 domain at a time

Hi, Live Link only seems to work for 1 domain at a time. Is this the expected behaviour? Im sure that I’ve had it running on more than one before.


I just tested enabling Live Links for 3 sites simultaneously on macOS and they all worked.

Are you still running into this issue? If so, are you on macOS or Windows? Also, what version of Local are you running?

Hi Clay,

Yes im still having the issue.

Im running latest version on windows 10



I tried to reproduce this on Windows 10 (64-bit) with Local 2.2.4. Again, I tested 3 sites simultaneously and all worked.

Can you please provide a screencast (or series or screenshots) of what’s happening?

Sorry for the trouble!

Hi Clay

There really isn’t any point me doing that as its quite simple.

I can enable one website but when i click the enable button for any other site it does absolutely nothing. In the logs it just says…

Jul 3, 2018, 12:01 PM GMT+1 - info: [main/ngrok-helper] Spawning ngrok for domainname.local


What version of Local are you running? You can find the version by clicking on the menu in the top-left and then going to About.

Also, are you on 32-bit Windows or 64-bit Windows?

Hi Clay, im running the latest version on windows 64bit

Can you try the following?

  1. Enable a Live Link for a running Local site (verify that the Live Link is working)
  2. Open three Cmd.exe windows
  3. In the first, run
%LocalAppData%\Programs\local-by-flywheel\resources\extraResources\ngrok\ngrok.exe http testing1.local:80 -log-level debug -host-header=testing1.local
  1. In the second, run
%LocalAppData%\Programs\local-by-flywheel\resources\extraResources\ngrok\ngrok.exe http testing2.local:80 -log-level debug -host-header=testing2.local
  1. In the third
%LocalAppData%\Programs\local-by-flywheel\resources\extraResources\ngrok\ngrok.exe http testing3.local:80 -log-level debug -host-header=testing3.local

These commands should provide some insight into what’s going on when you try enabling multiple Live Links.

Thanks for your patience!

Hi Clay, thanks for the update.

I get the following message in all 3 CMD windows…

Tunnel session failed: Your account 'Stuart' is limited to 1 simultaneous ngrok client session.

Aha, makes sense. In that case if you stay logged in with ngrok you will run into that limitation.

If you’re not paying for ngrok, I’d recommend removing your auth token. You can do so by removing/moving C:\Users\example\.ngrok2\ngrok.yml (example being your Windows username).

I didn’t realise I had an account, this must be because I used NGROK for my WAMP environment.

Thanks for the help

1 Like