Live Link Works But Styles Are Gone

Issue Summary

I’m posting this again because I couldn’t get a response to my last post:

I’m trying to use a live link and it works but all styling is gone. I am able to view the same site locally just fine when clicking “Open Site”.

Troubleshooting Questions

This is happening with two sites using Local

I am able to create a new, plain WordPress site in Local and access it in a Browser


I am enabling the Live Link, clicking on the link and entering the username and password

System Details

  • Version 6.1.2+5473

macOS Big Sur 11.5.2 on Mac Mini

local-lightning.log (664.2 KB)

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

I’m seeing a few lines in the Local log that look like this:

{"thread":"main","class":"Process","process":"nginx","level":"warn","message":"nginx: [emerg] still could not bind()","timestamp":"2021-09-10T14:49:56.506Z"}
{"thread":"main","class":"Process","process":"nginx","level":"warn","message":"nginx: [emerg] bind() to failed (48: Address already in use)","timestamp":"2021-09-10T14:49:57.136Z"}

This part:

bind() to failed (48: Address already in use)

Basically means that when Local is trying to get the site to listen on the 10018 port, something else is already there.

As a test, can you try:

  1. For that plain WordPress site, are you able to create a Live Link and access that site in the browser?

  2. If the plain WordPress site works over Live links, then let’s try freeing up that site. Fully restart the computer. This might free up that port and allow Local to register the site in that location.

  3. If that doesn’t work, try exporting the site, and import it into a new site in Local. Enable the Live Link for that site.

If there are still issues with that specific site, can you take a screenshot so that we can get a better idea of what kinds of styles are missing? Also, can you let us know if there are any page builders enabled on the site?

Thanks for the response Ben-

I just added a new blank site and enabled Live Link - it worked and styles for the default 2021 WP theme showed up. I then added a new blank site and imported my remote site into the blank Local site, enabled Live Link and got the same errors as before. Restarted computer and tried again - same result. Please see attached screenshots.

It’s hard to know why those styles aren’t showing up.

If you open the browser console, do you see any errors?

One possible thing is that the stylesheet is trying to be loaded over regular HTTP, but the site is running on HTTPS. Either way, examining the browser console should give you more info about what’s going on!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.