Live Links - Site loads to 50%, background images does not load on mobile (cURL error 60)

Issue Summary

Migrated a site from a XAAMP environment.

Now the site loads to 50% and some images don’t show up in mobile browsers when I use Live Links.

I had the same problem with the desktop version (that was an SSL issue). I changed to from http to https but that didn’t fix the mobile version. I have also updated all links on the page with the Elementor Tool.

Local 6.00 (Latest)

Windows 10
iOS 14.5.1

I get a cURL error 60: SSL certificate problem: self signed certificate error.
But I don’t know what’s causing it?

What’s the path to the php.ini in Local? I tried changing the php.ini.hbs found in “LocalSites/[SITE]/conf/php” by adding the line:

curl.cainfo = “C:/Cert/cacert.pem”

But it didn’t work.

I have tried WP Force SSL but it just gives me the same cURL error 60 message.

I really want to use Local, but this issue is making it difficult for me to to justify the move as I can’t use the software on mobile - which is why I started using it in the first place.

Does anyone have any advice?

Edit: I have spent 4 hours on this issue, how can I disable SSL in Local?

Do you have any screenshots of where you are seeing the error?

Typically that kind of error is associated with something trying to make an external request to another server.

The errors showed up on background images in the console in Chrome.

I updated the URLs and added the curl.cainfo to all php.ini files, and managed to get rid of the messages. But the images still won’t load on mobile.

2 days trying to fix this issue and I still can’t pinpoint what’s causing the problem on mobile.

The page works well on desktop, with different user-agents set in the browser.

I have tested the mobile version on iOS and Android devices, it just doesn’t work.

I have tried installing SSL Insecure Content Fixer that doesn’t work either.

It seems that for some reason, the CSS doesn’t load on mobile.

What could I try next?

The browser is extremely slow on SSL and will only load this much in a mobile browser:

I also get this message in Local, but SSL seem to work on the desktop version.

Tried on another computer now, and it just works locally with the Live Link. The URL on background images are not dynamic (whenever I change the URL to the Live Link, the local version stops working and vice versa):

I’m not sure if this is an issue with Local/Elementor or the theme?

Elementor saves styles to files, so maybe those CSS rules are still referencing the local site’s domain and not the Live Link?

I think I remember there being a setting in Elementor for not having it write those things to disk and instead have them generated with each page request. You might poke around in those settings to see if preventing Elementor from writing to CSS files will help with this.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.