Local 2.2.2 macOS can't find my sites


I have 10+ sites on local, and I updated yesterday to the last version (2.2.2) of the app. Since then, whatever I do, I am served a 404 error page when trying to access anything but the root of any site ; and a “It works!” page for the root of the site. I’m supposed to work on some of them.

SequelPro can access the site’s database, it’s all fine on this end.

I am on macOS 10.13.2 ; as said, Local is 2.2.2 ; what other piece of info can I give you to help me debug that ?

I have tried to check on /etc/hosts file, but it seems fine. I have rebooted the computer, it still doesn’t work. I’ve clicked off “faster docker volumes”, no change. I don’t see anything else to do. Any help please ?

Thanks by advance.

1 Like

That is really weird.

Out of despair, I saved my sites and reverted to Local 2.1.2. Installation fine, sites are still recognized and (hurrah !) the one I chose is visible (but empty, I just recreated it. So I copy the files - still fine. Then I import the database dump I had - and back to emptiness.

The only difference is now I still have a “It works!” page on front page, but I have a 403 Forbidden error page on any page/directory I try.

Could it come from the database ?

Hi @arthos,

This sounds like an issue with the IPv6 loopback.

Please try removing the Local entries in your /etc/hosts file that begin with ::1.

Well, it stopped not working (and I’m not sure exactly why). I had another problem because of the old .dev tld, and had to rename it in .local, but it’s working again.

I’ll update Local to 2.2.2 and try your solution if the problem happens again.

Thanks for your answer.

I’m having the same problem on Win10. Can’t access any of my sites.
Tried editing the hosts file by removing the lines starting with ::1 but still nothing.