[High Sierra] Local Sites Refusing to Connect (Local 2.0.6)

I just updated to Local 2.0.6 and have encountered an issue loading my sites. When I start each site, I no longer get a notification that the site is running and I get an ERR_CONNECTION_REFUSED page when navigating to the .dev URL. It may be important to note that I am on macOS 10.13 beta. Is there anything I can do on my end to get this resolved?


Here’s my log file from the past few days for good measure.

Hi Justin,

Unfortunately macOS High Sierra isn’t supported at this time simply because there are a lot moving parts in Local including VirtualBox, Docker Machine, and Docker.

We’re keeping an eye on High Sierra, but it’s hard to tell if the problem you’re running into is caused by 10.13 or not.

With that said, I’m not seeing anything in the log file that’s particularly alarming, but one thing you can try is going to Help » Restart Local’s Machine. Also, I would try running ping on your Local site URLs to see if there’s any response.

Is there any way to alternatively access the sites without the .dev domain? I ran a ping on one of the domains and received packets back. Navigating to the IP in the hosts file ( also brings up the connection refused page.

Accessing it with the IP is how you do it but it looks like the router container isn’t properly starting.

Can you send the log file again?

Also, can you run the following in Terminal?

  1. Run: eval $("/Applications/Local by Flywheel.app/Contents/Resources/extraResources/virtual-machine/vendor/docker/osx/docker-machine" env local-by-flywheel)
  2. Run and provide output of: "/Applications/Local by Flywheel.app/Contents/Resources/extraResources/virtual-machine/vendor/docker/osx/docker" ps

Here’s the full log: https://drive.google.com/file/d/0B_voLkNNJYx2ZUlJb2JrRVE4UXM/view?usp=sharing

Here’s the output of that command

CONTAINER ID        IMAGE               COMMAND                  CREATED             STATUS              PORTS                                                                                         NAMES
9eb8141a33d2        custom:1.2          "/etc/scripts/slee..."   27 hours ago        Up 24 minutes>80/tcp,>443/tcp,>1080/tcp,>3306/tcp   sad_ride

Sorry for the bump, but I’m still having the local router issue. @clay, did you get a chance to review the output posted above?

Hey @justin,

Can you try restarting the site in Local and then sending the log file again?

Thanks for your patience!

Here’s the new log file: https://drive.google.com/open?id=0B_voLkNNJYx2ZUlJb2JrRVE4UXM


I’m not seeing anything out of the ordinary in the log file. After you did that, is the site still not accessible?

If not, I’ll try to reproduce this on the High Sierra beta when I get a chance.

Correct, I’m still not able to access any of my sites. I had everything working on High Sierra initially, but after updating to 2.0.6 I ran into this issue. I tried downgrading back to previous versions, but the issue persisted.

Let me know if I can provide any more information to help out.

Can you please try the following commands in Terminal?

Run the following:

eval $("/Applications/Local by Flywheel.app/Contents/Resources/extraResources/virtual-machine/vendor/docker/osx/docker-machine" env local-by-flywheel)

Run the following (be sure to copy and provide the errors you see):

"/Applications/Local by Flywheel.app/Contents/Resources/extraResources/virtual-machine/vendor/docker/osx/docker" logs $("/Applications/Local by Flywheel.app/Contents/Resources/extraResources/virtual-machine/vendor/docker/osx/docker" inspect -f "{{.Id}} {{.Config.Cmd}}" $(docker ps -a -q) | grep "nginx -g daemon off;" | awk '{print $1}')

nginx: [emerg] BIO_new_file("/etc/nginx-router/routes/certs/doubleupdigital.dev.crt") failed (SSL: error:02001002:system library:fopen:No such file or directory:fopen(’/etc/nginx-router/routes/certs/doubleupdigital.dev.crt’,‘r’) error:2006D080:BIO routines:BIO_new_file:no such file)

Try running the following. Then, open Local and restart any site.

rm -rf ~/Library/Application\ Support/Local\ by\ Flywheel/routes

Tried it out, still returning the connection refused page. Still missing the site started notification as well.

Seems like there might be an issue with Local generating certs on High Sierra.

Can you run the commands above again and then run?

ls -la ~/Library/Application\ Support/Local\ by\ Flywheel/routes

Thanks for helping out!

Here’s what I get before clearing this directory

total 96
drwxr-xr-x 15 justin staff 480 Jul 26 16:06 .
drwxr-xr-x 26 justin staff 832 Jul 26 16:06 …
-rw-r–r-- 1 justin staff 2313 Jul 26 16:06 bermacsafety.dev.conf
drwxr-xr-x 2 justin staff 64 Jul 26 16:06 certs
-rw-r–r-- 1 justin staff 2331 Jul 26 16:06 doubleupdigital.dev.conf
-rw-r–r-- 1 justin staff 2385 Jul 26 16:06 fivepalmsvacationrentals.dev.conf
-rw-r–r-- 1 justin staff 2301 Jul 26 16:06 fsagallery.dev.conf
-rw-r–r-- 1 justin staff 2331 Jul 26 16:06 hiddenlinksgolf.dev.conf
-rw-r–r-- 1 justin staff 2307 Jul 26 16:06 insightpool.dev.conf
-rw-r–r-- 1 justin staff 2325 Jul 26 16:06 justinradomski.dev.conf
-rw-r–r-- 1 justin staff 2313 Jul 26 16:06 mag-nificent.dev.conf
-rw-r–r-- 1 justin staff 2289 Jul 26 16:06 prcroofs.dev.conf
-rw-r–r-- 1 justin staff 2325 Jul 26 16:06 reviews4gamers.dev.conf
-rw-r–r-- 1 justin staff 2307 Jul 26 16:06 southernweb.dev.conf
-rw-r–r-- 1 justin staff 2265 Jul 26 16:06 tokn.dev.conf

Would the certs be the source of the problem even if I haven’t set up SSL on Local?

Local automatically creates certs for every site even if you don’t use HTTPS.

Can you go ahead and run the following? I’m curious to see what’s in the certs directory if there is anything.

ls -la ~/Library/Application\ Support/Local\ by\ Flywheel/routes/certs

total 0
drwxr-xr-x 2 justin staff 64 Jul 26 16:06 .
drwxr-xr-x 15 justin staff 480 Jul 26 16:06 …

Gotcha. Directory appears empty.

I’m in the same boat - has there been any progress here?

1 Like