Local Community

Local 5.9.8 ; new site creation failed

  • environnement : Windows 7 edition famille prémium
  • Flywheel version installed : 5.9.8

I started “Local” as administrator, and tried to create a new site (“essai02”)
But the creation of new site (“essai02”) failed :
I got an Error pop-up saying:
"Unable to provision site
"…can’t connect to MySQL server on ‘::1’ 10061
Prior to this error pop-up, il saw a little Blue popup saying :
" local is requesting admin privilege to modify your
" */etc/hosts file

I could attach the “local-lightning.log” file …but i don’t know how to attach a file to the topic…sorry about that.
Thanks for your helperror local-lightning.log (10.6 KB)

From the error:

Error: Command failed: %%resourcesPath%%\\lightning-services\\mysql-8.0.16+5\\bin\\win64\\bin\\mysqladmin.exe --password= ping
mysqladmin: [Warning] Using a password on the command line interface can be insecure.\r
\u0007mysqladmin: connect to server at '::1' failed\r
error: 'Can't connect to MySQL server on '::1' (10061)'\r
Check that mysqld is running on ::1 and that the port is 10005.\r
You can check this by doing 'telnet ::1 10005'\r

    at ChildProcess.exithandler (child_process.js:304:12)
    at ChildProcess.emit (events.js:223:5)
    at ChildProcess.EventEmitter.emit (domain.js:475:20)
    at maybeClose (internal/child_process.js:1021:16)
    at Socket.<anonymous> (internal/child_process.js:430:11)
    at Socket.emit (events.js:223:5)
    at Socket.EventEmitter.emit (domain.js:475:20)
    at Pipe.<anonymous> (net.js:664:12)

It seems like maybe MySQL is trying to connect over IPv6 (that’s the ::1 part of the error)

Windows 7 is fairly old, so I wonder if there’s an issue with how it’s resolving IPv6? Do you have any way of upgrading to a newer version of Windows?

Hello …Thanks for your answer.
As suggested, i used my son’s PC which running windows10 to install local 5.9.8
But when I tried to create a new site (“essai2021”) I got the 1rst error pop-up (see “flywheel-error-01.png” )
However the creation process continued …but displaying the orange Warning message , complaining about the missing Hosts entry … (see “flywheel-error-02.png” )
And as expected when I tried to get ADMIN Dashboard, Firefox failed to connect the new site (see “flywheel-error-02.png” )
flywheel-error-01

local-lightning.log (74.7 KB) flywheel-error-01 local-lightning.log (74.7 KB) flywheel-error-01 local-lightning.log (74.7 KB)
I attached the “Hosts file” as well as the “local-lightning.log” .
Thanks for your help !!
Regards

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.