Local Community

Local by flywheel couldn't connect to wordpress.org - Ubuntu

Issue Summary

I connot connect to wordpress.org and can’t add or update plugins/themes, this issues affecting other plugins that need connection and causing errors or fatal errors sometimes.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular? All

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser? Yes

Replication

Same problem described here but in Ubuntu:


But I don’t know how to apply it in Ubuntu and not sure if it includes the lightning update.

System Details

  • Which version of Local is being used? The latest for Ubuntu/Linux

  • What Operating System (OS) and OS version is being used?

    • Ubuntu 20
  • Attach the Local Log. See this Community Forum post for instructions on how to do so:

What’s the specific error you are seeing, and where are you seeing it?

From the local log, I’m seeing a few lines that mention the disk being full:

{"thread":"main","class":"Process","process":"mysql","level":"warn","message":"2021-01-19T19:06:41.244988Z 293 [ERROR] [MY-000035] [Server] Disk is full writing './binlog.000008' (OS errno 28 - No space left on device). Waiting for someone to free space... Retry in 60 secs. Message reprinted in 600 secs.","timestamp":"2021-01-19T19:06:41.247Z"}

Thanks for replying,
I get the error in the WP Dashboard, and in Site Health, it say connot connect to Wordpress.org.
I had two disks, it shouldn’t be a problem.
I am getting the exact same issue in the attached FAQ thread, but in Ubuntu.
However, when I switch to PHP8 it seems I get connected to wordpress.org, but most themes and plugins don’t support php8 so I still need php7.
Regards.

I am also getting the same error in Ubuntu 20.04. When I create a new site using default PHP 7.3 everything works when I switch to another version of PHP e.g. 7.4 the error appears. After the switch it doesn’t matter which version of PHP I switch too. I cannot install new plugins.

Thanks for clarifying @YTF and @garikaib – I wonder if the PHP lightning service needs to be updated for the php versions that are having problems. Maybe getting the latest version will update the certificates that PHP uses to connect remotely to wordpress.org.

Can you try following the steps in this help doc and let me know how it goes:

Hi @ben.turner , thanks for your suggestion, unfortunately it did not work, I am still having the same issue.

I’ve been trying to replicate on my Ubuntu machine but I’m able to update the plugins from within the WP admin.

Instead of switching PHP versions, what happens if you create a new, plain site with the PHP version you are intending to use?

If you are still having issues, it would be good to know what the specific PHP error is. Can you zip up the logs folder for the site so that we can look at the logs/php/error.log file?

Hey,
I tried using php7.4 on new installation, still the same.
This is happenning on all installation that are using php7.4 on Ubuntu, I have it on Windows too but the error doesn’t happen, however the websites are very slow so i use ubuntu.
Here the folder:
logs.zip (4.9 KB)
Thanks

Earlier you mentioned that the “full disk” error shouldn’t be a problem:

Can you elaborate on that?

There doesn’t seem to be anything wrong within the server log, and the only errors in the Local log are related to running out of disk space. This could definitely have corrupted things within the Local configuration folder and if that’s the case, you might need to completely uninstall Local and re-install it so that everything is set up correctly.

I tried the solution in the linked article but it did not fix my issue. Still having issues connecting to WordPress.org for some reason. Deleted components were re-downloaded but that did not fix the issue.

I have 500GB SSD and 1TBSata, I even changed the installation folder and still getting the same error.
If the disk space is the problem, then why would it work with php8 or php7.3?!
I got this from error.log in apache

Blockquote
AH00558: httpd: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1. Set the ‘ServerName’ directive globally to suppress this message
[Thu Feb 18 09:51:23.029872 2021] [mpm_event:notice] [pid 7874:tid 140608856964416] AH00489: Apache/2.4.43 (Unix) configured – resuming normal operations
[Thu Feb 18 09:51:23.030139 2021] [core:notice] [pid 7874:tid 140608856964416] AH00094: Command line: ‘/home/ahmed/.config/Local/lightning-services/apache-2.4.43+6/bin/linux/bin/httpd -D FOREGROUND -f /home/ahmed/.config/Local/run/rrGKZ5Wzl/conf/apache/apache2.conf’

Attaching another error log
logs.zip (4.3 KB)
Thanks

There’s not much info here regarding what’s going wrong. If I search the WordPress codebase for that error message, it looks like it’s coming from here:

I think that the conditional on line 175 is testing for SSL support as well as if this is a WP_Error.

Can you turn on debugging as well as logging the WordPress errors to see what issues WordPress is encountering? To do this, add these lines to the wp-config.php file:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );

https://wordpress.org/support/article/debugging-in-wordpress/

From there, re-try installing plugins and then see what errors are showing in the

wp-content/debug.log

Can you reply with that log so that we can see why WordPress is having issues connecting?

Hey, I just tried that, here is the debug.log
debug.log (6.2 KB)

I turned on SSL trusting in the Local, doesn’t seem to do anything.

@YTF can you report the following paths?

  1. Path of Local.app
  2. Path of where you are saving your Local sites

Sometimes there are issues if the application and location of saving the sites is not the boot disk. @ben.turner can confirm or not, I might be mistaken.

The debug.log doesn’t have much more for us to go on, so I’m thinking that this is hinting at more of a networking issue.

Where are you running this ubuntu box – is this within a VM, or do you have it running as a dual boot system?

One other thing, how is this system connecting to the internet? Are you using a VPN, or some other firewalls or security settings? Maybe something within the router’s settings?

This setting has more to do with registering an SSL certificate with the computer’s browser as opposed to adjusting the configuration of the SSL certificate that is used to make external requests from the WordPress site.

I usually see issues like this related to Windows, but it’s still a good idea to explore.

I have Ubuntu as a dual boot, I had local before and it was working, why would it work with php8 or 7.3 and not 7.4?

I think I see what’s going on here – I was able to replicate on PHP 7.4.1

It looks like there is a different version of GLIBC_2.29 in Ubuntu and this is what PHP 7.4.1 is expecting.

To replicate, here’s what I did:

  1. In Ubuntu (mine was 20.04.2 LTS)
  2. Create a new, custom site using PHP 7.4.1.
  3. Navigate to the plugins page and note that you can’t install a plugin
  4. Create a new, Preferred site, which uses PHP 7.3.5
  5. Navigate to the plugins page and note that you can browse and install plugins

As a troubleshooting step, I was going to look at the phpinfo for each site using php -i but I couldn’t open the terminal for the 7.4.1 site. Here’s the specific error that was showing:

/bin/zsh: /home/benjamin/.config/Local/lightning-services/php-7.4.1+14/bin/linux/shared-libs/libm.so.6: version `GLIBC_2.29' not found (required by /bin/zsh)

It looks like we need to adjust some of the PHP lighting service settings. I’ve created a bug for our devs to take a look at, but I don’t have an ETA for when that will be worked on. In the meantime, I’d say using the Preferred environment with the 7.3.5 version of PHP is the best work-around.

2 Likes

This is great, at least we know the problem, that’s what was affecting me more than the problem itself ( not knowing what is it)
Thanks for your help, let hope we get a fox soon as most plugins don’t support php8 yet

This is happening on macOS too (latest Local + Mojave). Every PHP version.

Hey @mediacloud – I wasn’t able to replicate on my Mac.

Can you provide a bit more context? One thing to try is to ensure that the latest version of the PHP lightning services is installed. Can you try updating those to the latest version: