"Local couldn't load the file list!" when trying to push to wpengine

Issue Summary

Local has been working fine for me this week until today, and I’m not sure what changed. Today, when I tried pushing my work up to our dev server for this site on wpengine, it started giving me the error “Local couldn’t load the file list!”.

When I try pulling, all the files come up so it seems to work there… I just can’t push. I downloaded and installed an update for Local today, so it might be related to that? Otherwise, I’m not sure what would’ve changed between yesterday and today.

And everything else still seems to work - I can still run sites and access them like always.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    All sites

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?


Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

  1. Try to push a WPEngine site up
  2. See the error “Local couldn’t load the file list!” instead of the usual list of modified files to be pushed

System Details

  • Which version of Local is being used?
    Version 7.1.0+6396

  • What Operating System (OS) and OS version is being used?
    Mac OS Ventura 13.4.1

  • Attach the Local Log. See this Help Doc for instructions on how to do so:
    local-lightning.log (377.1 KB)

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.


This is related to a known bug we are investigating at this time. We should have a fix for this rolled out later today and I’ll update you when that’s ready!

Thank you so much, fellow Nick B!

That at least makes it easier on my end. Thanks for all you do with this great piece of software.

1 Like

We’ve got a Beta version rolled out with a potential fix. Check out the link below for more details:

Thank you, looks like that worked for me!

1 Like

Glad to hear it @NikoB! Happy Developing :slight_smile:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.