Local does not work with Chrome, only Safari and Firefox on Mac

I installed Local on my Mac with Mac OS 10.11.

Chrome or Chrome-based browsers (likeVivaldi) cannot connect to my local website installation using Local.
They give an error stating “ERR_CONNECTION_REFUSED”

Safari and Firefox work well.

Anyone can help?

1 Like

Hi Romeo,

Can you please try the steps in this blog post?

Sorry for the trouble!

I’d love to get this resolved. Local looks great compared to the competition. I love being able to change PHP versions on the fly.

I cleared the Chrome Browser DNS Hose Cache on both Chrome and Vivaldi as outlined above.
It did nothing. I still get the error message that I cannot contect

In Chrome I get the following error:

This site can’t be reached
mywebsite.dev refused to connect.
Checking the connection
Checking the proxy and the firewall

In Vivaldi I get two error messages - one following the other:

This site can’t be reached
mywebsite.dev refused to connect.
Checking the connection
Checking the proxy and the firewall

The following error message then replaces the first error message spontaneously:

Access to mywebsite.dev was denied
You don’t have authorization to view this page.

Note: I installed the website locally in the shared user directory: /Users/Shared/Shared Files/WEBSITES LOCAL/mywebsite
I did not install it in my own user directory: /Users/MyAccount/Documents/WEBSITES LOCAL/mywebsite

I wonder if there is some weird permissions problem that is affecting Chrome and Chrome-based web browers such as Vivaldi.

Having this same issue fairly regularly. Once and a while it resolves itself, but these troubleshooting steps did not help?

Any further suggestions?

I solved it.

The problem is the fake SSL certificates that Local creates when you turn on that features.

Google Chrome does not trust the certificates that Local creates. So this is why trying to access your .dev local website fails.

On the Mac, I go to Keychain Access and search for the .dev SSL certificates. Then erase all of them.

On the PC, erase the .dev SSL certificates where they are stored.

Then Chrome and Chrome-based web browsers such as Vivaldi work.

I am having the problem now, I deleted the .dev profiles but still not working on Chrome?

Hi @squarepixel,

What error are you seeing?

Have you tried clicking the “Trust” button under the site’s “SSL” tab in Local?

@clay it will not let me load the page at first, it keeps trying to force SSL (the site is not SSL) so I do go and click Trust and then the site shows up but no correctly.

In that case, you’ll need to change the site’s TLD (.dev) to something else like .local or .test. You can easily change a site’s domain in Local by going to the site in Local and then clicking on “Change Site Domain”

Chrome 63+ forces all .dev sites to use HSTS which forces HTTPS.

Great, I will do that. Thanks so much for getting back to me :slight_smile:

1 Like

Hi Clay, I’ve tried all the suggestions listed on this thread so far and still cannot get Chrome or Safari to connect to the development site. Here’s the error message I get.

This site can’t be reached
gardeningbuddy.test refused to connect.
Search Google for gardeningbuddy test admin

I’m using an iMac with OS10.11.6 running on it. Any other suggestions?

I dont know if it will help, but I changed my sites to .local and they are working fine. Maybe give that a try?

.dev is owned by Google and is now enforcing HSTS by Chrome.

This is covered in several other threads, as well as widely around the internets…

Local now defaults to .local. Although personally since the spec for .local is reserved for multicast DNS I use .test. It’s extremely unlikely anyone will run into conflicts with .local but we thought that about .dev once upon a time…

Thanks for the idea. Unfortunately my site was a .local to begin with. I tried changing it to see if using .test might work. For now I’m giving up on getting it running on my iMac and will just have to stick with my laptop, which really isn’t enough real estate for me to comfortably develop, but gotta work with what works, eh?