All Local flywheel sites Invalid certificates and privacy error


So randomly all of my local site won’t load on any browser. I get a privacy error "# Your connection is not private
Attackers might be trying to steal your information from (for example, passwords, messages, or credit cards). Learn more


However, when I inspect the certificate it look suspicious.

Attached are images.
51 PM59 PM


my local is doing the same thing


I’ve got the same problem… Hope we’ll have our answer soon :confused:

But now, there’s a solution (kind of)…

When you enable the live link, you can work from that (it’s maybe not the greatest solution, but it work)

1 Like

Hi everyone

This explains the issue:

Hence why Local now uses .local as it’s default extension. If you change you chnange your domain to .local it should work

1 Like

I am having the same issue.

@kylecraventhanks so much, it worked for me. :grinning:

Change the sites domains from .dev to something like .local. This should resolve your issue as .dev is now a valid tld. :slight_smile:

Do you have to change the site domains manually? Or will it work for local to update everything for you?

I changed the site name, the site domain name, and the path name on my hard drive from .dev to .local. It still gave the privacy error in Chrome. I tried changing everything back to .dev, planning to use Safari instead. Now when I try to connect in Safari, the browser changes .dev to .local and can’t find the site. Tried restarting Local and then the computer.

Any ideas how to be able to open the site again?


I’m having problems with this as well…I’ve changed my domains from .dev to .local and a few sites worked, some just sit and spin forever. Now I’m trying to access some that were working and now they all just spin and it sounds like my MacBook Pro is going to spin off. Is there a list of steps to take an existing Local by Flywheel site that has .dev to get it to .local to work properly in the latest Chrome and Safari versions please?

Hey guys, I actually found another solution. You just have to re-trust your SSL certificate in the sll tab. 08 PM


Thanks! I just encountered this problem and clicking “Trust” solved it.

1 Like

@clay wondering if you found any solution here? My hostfile is as follows:


Can you screenshot the error that you’re seeing?

Sorry for the trouble!


- changing to .local doesn’t work either, but is all working in safari…


Just a heads up I moved your posts into this thread since it’s more relevant.

If you’re still running into this error with .local then you’ll need to click the “Trust” button above like @keli5466 mentioned.

Clicking the Trust button will also fix this issue on sites still using .dev.

@gscoolidge ,

Are you still having trouble with some site domains not changing?

Hi @clay! Yes, most of them resolved themselves when I shut off my Mac and restarted. But I have one that won’t work, I exported it, deleted the site then imported brand new and it now gives me a 500 internal server error , any tips ?

@clay Update! The site I was having problems with is working now. I went into the database and noticed in wp-options, the siteurl and home paths still showed .dev. I changed them to .local and now it is working.

1 Like

This caught me out for a day trying to figure it out. but once i switched to .local all was fine.