Local + Elementor Pro Loop Grid + ACF = Undefined array key "product_query_post_type"

What issue or error are you experiencing?

Hi. First, really like local. Its been a great resource to test sites prior to version upgrades.

The issue I’m having is on any site running on Local that uses Elementor Pro’s dynamic loop grid pulling data from an Advanced Custom Fields page, throws the below error. This is only when running on Local. On the live site, there is no error.

( ! ) Warning: Undefined array key “product_query_post_type” in /Volumes/Site Backup/Local Sites/-----name of site-----/app/public/wp-content/plugins/elementor/includes/conditions.php on line 87

That warning appears above each instance of a loop grid. Additionally I get that exact same message on other sites (different site name) with the same setup within Local.

What’s really weird is if I set Local to have the exact same MySQL and PHP of the live site. I still get that message.

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

On a live site, build out the below:

  • Install Elementor Pro
  • Setup an ACF text field
  • Create an Elementor Pro dynamic loop grid element that pulls the ACF field info from a page (photos, text, etc…)
    Manually pull a backup (in my case through WPengine) and set up the site on local (either same host settings /or/ let it use auto settings for latest PHP and MySQL)
  • Run site and view loop grid page to see error (its always duplicated twice with the same line #)

Thanks. And again, really like Local. Its been great to test PHP and MySQL version updates.

System Details

  • Local Version:
  • Operating System (OS) and OS version:
    Mac OS 11.7.6

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

Log info:
local-lightning.log.zip (6.3 KB)

Xdebug error warning info:
xdebug-warning-info.txt.zip (8.4 KB)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hey @Rfleming! I just did a quick search for your error and saw this Github bug that was sent to Elementor and they are looking into. Have you seen this?

Thanks Nick, I did see that but wasn’t 100% sure it was related to the same issue or resolved since it was posted back in June. I’m torn on if the issue is Elementor directly or something that’s just not firing when I run a site on Local vs. WPengine. It’s an odd one. Everything displays correctly on my host server, but I only get that error when running on Local.

Thanks though. Appreciate you looking! I’ll fire off the same question to the plugin developer as well.

I can check with the Devs on this as well but it might be worth running by Elementor also. Because it works on the live site but not in Local it makes me think that it could be a limitation somewhere. We’ve seen this come up with other Pro plugins in the past including Elementor where certain functions just don’t work the same or at all in Local vs a live site. Or they can only work on one site at a time because of the license. That’s kind of what this is smelling like to me but not 100% yet.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.