Local WP - Fatal Error: Uncaught TypeError

I’ve been using local wp for a year now. Yesterday, i was showing the progress to my client through live link option. After showing him i tried to refresh the page with new changes i had made a few minutes after the online meeting.

Right now, i can access the website because i’m having a Fatal Error: Uncaught TypeError: Cannot access offset of type string in (…)

I know the elementor plugin is responsible for this error, i’ve tried to rollback versions, delete the plugin and reinstall it…Nothing worked.

I’m also awared that this is a local WP community and not a elementor one but I really need support and elementor only helps if you’re pro.

System Details

Local Version: Version 9.0.4+6699

Operating System (OS) and OS version: Windows 11 Pro 23H2

Local Logs
local-logs.zip (82.7 KB)

Hi @FranciscoAbreu

It could be a conflict with another plugin or theme. So you could also try deactivating everything and see if that works, or try swapping out the theme. If you can’t get into the backend you can use Open Site Shell in your Local app to spin up a shell window and do CLI commands like this:

wp plugin deactivate --all

If you just deactivated and deleted the Elementor plugin from the WordPress dashboard, you might also check in your site files if it left anything behind. There could still be a configuration folder or something lingering so that it’s not fully gone.

Hi @Nick-B ,

Thank you for your help. I’ve tried to swap themes and the error persists. I deactivated all of the plugins and only when i have elementor plugin on the error triggers. When i deleted the elementor plugin, there was nothing left

I don’t really understand the reason for this error but it all started when i tried to live link.

With Elementor removed from the site could you try exporting it into a zip, deleting it from Local, and then reimporting it again?

just did that, should i try to install elementor now?

it keeps showing the same fatal error on line 242

And this is the code where the error triggers on base.php

protected function get_saved_assets_data() {
$assets_data = get_option( self::ASSETS_DATA_KEY, );

	$content_type = $this->content_type;
	$assets_category = $this->assets_category;

	if ( ! isset( $assets_data[ $content_type ] ) ) {
		$assets_data[ $content_type ] = [];

	if ( ! isset( $assets_data[ $content_type ][ $assets_category ] ) ) {
		$assets_data[ $content_type ][ $assets_category ] = [];
	return $assets_data;

I checked with our team and @nickc noted that Elementor has a bug report here with some suggested fixes threaded that might be worth trying:

1 Like

I have to thank you Nick! the suggestion of recreating/regenerating elementor CSS files (elementor > tools > general > recreate/regenerate CSS and data) worked perfectly. This is an odd error with such a easy fix. My mind was going crazy lol Thank you


When I saw that in there I was thinking surely it’s not that simple? If only more things were that easy :slight_smile:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.