Local has lost my ID

Hi, I have been using Local by Flywheel for most of the day, in conjunction with watching a Udemy course in Wordpress Development, so I can learn in real-time. I restarted my pc and when I tried to open the Local app again, it won’t open. So I uninstalled then reinstalled. On reinstallation the local machine is working and stops, then before I click on my site name it goes back into search mode. Then when it stops again I manage to click on my site name and an error box appears saying ‘Site Not Found Uh-oh! Your ID has not been recognized’.
Now when I click on the icon it won’t even open.

Can anyone help me please?? Thanks!

Same here.

I solved this bij making a zip file of the site I wanted to restore and importing this. Not too much work. I did had to give the site a new name though.

hi jan - I have no idea how to do that, but thank you anyway.

Hey @cumfnum -

That doesn’t sound good – almost as if the running site wasn’t cleanly shut down before restarting.

You can always take a backup of a site by right-clicking on it in Local and selecting “Export”. This will give you a zip file that can be used to restore the site fairly quickly.

We might be able to see if there are more clues as to what went wrong by looking at the Local log. Can you please provide your local-by-flywheel.log file? See
How do I retrieve Local’s log file?” for instructions on how to do so.

– Ben

Hi Ben, thanks for getting back to me and I’ve attached the log you requested.


local-by-flywheel.log (366 KB)

It looks like things are ok now Ben.

tnx from num.


  1. go to the directory which has your site in it on your pc. Should be a subdirectory of Local Sites. Make a zip file of the whole directory.
  2. In local at the upper left corner, click import site.
  3. Browse to the zip file you’ve made
  4. Give your new site a name - should be an other one than the old one.
  5. Import.
1 Like


I did that (I made a zip file of the folder inside the local sites> was this right?)

On local I imported zip file.

I get an ERROR Uh-oh, it looks like we couldn’t retrieve the requested Docker iamge.


After doing what you told me with the zip file and importing it, Local Machine now says Uh-oh! The requested site IUD does not exist in Local.

I have 4 sites and it says this on each one.

And now after all that I have my sites up and running through Local.

It’s working! It takes time but it get’s there.



OK, so problem solved (sort of).


Great to hear @cumfnum !

Thanks for sharing what you did to get it working!

– Ben

I don’t know where I go wrong! It’s happening again saying id not found in local. What I did was delete all sites, then uninstalled local, rebooted and reinstalled local, added a new site and the same error appears uh oh! ID not found. I wish I could start over again. A fresh clean install with no connections to previous.

My other email that I use for Wordpress and Local is rob_walks@hotmail.com aka cumfnum.

Later on today (as I’m in bed atm trying to sleep) I will mail you the version of Local I am using along with the log for you to look at if you wouldn’t mind. I’m at a loose end in knowing what to do now and my learning of code was coming aling quite well nor a beginner.

Thanks & goodnight.


Hi Ben, I have noticed that the local program is quite slugish, meaning that upon start up I do get error warnings, however if I wait a short while, maybe until the connections join…

I think it’s really great how you guys do what you do in helping all off us, and I find it very helpful not only in answering my questions, but in me asking and then trying to work the problem out myself.

I hope you don’t mind.


I think this is the best way to learn. I can’t tell you how many things I’ve “solved” after trying to work out a good way to ask for help. It’s like the process of formulating a question makes you re-visit things and find the holes in your knowledge!

When Local starts, for example after rebooting your computer, it can take a little bit of time before everything is loaded up into memory. Part of what makes Local so flexible is that it is operating a Virtual Machine – this is great for having some isolation of the kinds of programs that are being run, but you can think of it like starting your own operating system. It takes a minute or so for everything to load.

As for slowness starting sites, this is similar to starting Local, but should be done within a minute. I’ve ususally noticed that the slowest thing when starting a site is waiting for the database to finish loading.

Once everything is loaded, is everything working as you expect it to? Does WordPress respond in a timely manner for you?

– Ben

Hi again.

I’ve just started Local for the first time today. or yesterday come to that. I am getting the Uh-oh! error everytime I am asked to choose a site, however I’m seeing that Local is restarting the ‘Checking System’ over and over, and over.

So I have around a few seconds to click on my site name - and then after that I’m getting the error box.

I am lost in knowing what to do with this now. The only thing I have thought of and tried, is uninstalling then re-installing which left me with the same problem.

I can’t figure out how to install Wordpress directly to my pc either. Is it a case that I HAVE TO get to Wordpress through Local by Flywheel? or Can I just install Wordpress onto my pc and use it in the same way? And now Local won’t even start after I click on the icon. Nothing.

Can we talk on the phone?