Local is either very very slow or buggy

Issue Summary

Local used to only be “kind of” slow (a few seconds per action in WP, which was frustrating and slowed down my work significantly, but it was manageable).

Now, it’s gotten to be unbelievably slow (up to a minute per change, now any little thing that used to take me 15 seconds takes 5-10mins and I am 90% less productive when working with local. It’s almost unusable). This has been the case for the past few weeks and I’ve continued to investigate it. We had problems with xdebug before and disabling it fixed the problem for some of us. However, I’m no longer able to disable it, and tried removing xdebug from the config file, but it’s still enabled and very very slow. I changed from php 8.0.0 to 8.1.9 (latest). The last time I changed versions, it required several computer restarts, server restarts, and all sorts of debugging for hours in order to get everything functioning again, so I was very, very, very hesitant to change to 8.1.9. However, my coworkers are on that version and suggested it again. After changing, thankfully, everything seemed to work, and now everything is blazing fast (maybe 1-2 seconds per action). However, local is extraordinarily buggy. Creating a new blog post sometimes gives me 404s, sometimes redirects to the blog home, and either way is never published. I get errors saying I’m missing fields that I’m not, and it’s randomly deleting my data. I never encountered any of this before. But at least it’s fast. So needless to say, I also cannot work like this.

I’m reaching out here because I’ve run out of options (and the support here is pretty good), and I’m still insistent on using local because 1) it’s what we use at work and I don’t think I have a choice anyway and 2) it’s still by far better than any competition :smile:

Thank you in advance.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?


Steps described above, but I just have a local site and have changed php versions and attempted to disable xdebug.

System Details

  • Which version of Local is being used?


(it’s dumb that I can’t copy the version from the version pop up… isn’t that the entire purpose of showing the version to the user so they can tell support what version they’re on?)

  • What Operating System (OS) and OS version is being used?

Windows 10

  • Attach the Local Log. See this Help Doc for instructions on how to do so:

Ideally not attaching log for security reasons. I can send it to a support agent if they reach out.

Hi @justingolden! Have you seen our help article on performance here? We recently updated it with a couple of Windows-specific details that might be worth trying:

I’ll take a look. Thanks Nick!


I’m also noticing that I’m getting lots of 404s after adding pages. I’m on php 8.0.0 and didn’t have this problem before on php 8.0.0, only had that problem on latest php.

EDIT: 404s were caused by permalink problems for our specific theme, and has been resolved. After reinstalling and changing php versions and fixing the permalink problem, 404s and performance has been resolved.

Hey @justingolden We’re glad to hear that you were able to resolve both issues! Happy Developing :green_heart:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.