Local keeps resetting .local domain to localhost:10029

Local keeps resetting .local domain to localhost:10029.
This has wreaked havoc with my WordMove migrations and keeps breaking live sites.
It’s sometimes also running very slowly.

Please offer a solution to this!

Hi @optimystery,

If Local is switching to use site domains like localhost:10029, there’s likely another web server running on the ports that Local needs for the Site Domains Router Mode.

I recommend making sure other web servers like IIS, Apache, and Nginx are disabled if installed.

For more details on the Local Router mode, see https://localwp.com/help-docs/router-mode/