Local Lightning 5.0.6 Mac OS doesn't recognize Sequel Pro nightly build

I’ve been using the latest nightly build of Sequel Pro for months, also on Local by Flywheel. I just installed Local Lightning 5.0.6 and it’s very fast and seems to work well so far.

However, I see “Download Sequel Pro” in the app instead of the expected Sequel Pro launch button. I’ve rebooted, and verified that the latest nightly build of Sequel Pro is running fine on my system.

It seems that other folks have this working fine; could my problem be related to the fact that I’ve had the nightly build since before I ever installed Local Lightning?


I have the same issue. Use the nightly Sequel Pro, mostly for Dark Mode support and having multiple filters at once. Just updated Local Lightning, and now it wants me to download the stable (and years old) Sequel Pro. Is there a way for me to get Local to recognize the nightly Sequel, or does this need to wait for an update? In the meantime, is there a way for me to manually launch Sequel to Local DB?

I can confirm this too.

The Sequel Pro nightly still works but in Local 5.0.6 there is only a “Download Sequel Pro” button. Where we used to be able to open Sequel Pro with one click that seems to be gone.

I can also confirm that opening Sequel Pro nightly and connecting via socket with the database information does work.

FWIW I’m using Catalina.

I hadn’t thought to try connecting directly with the socket info. That works on my end too, still using Mojave. Thanks for the workaround!

Same here.

@afragen how to get the socket connection data (might be that this is actually more obvious than I think right now)

If I got it right the sequel pro version was needed because Local 5.x right now just supports MySQL 8.x and the nightly version is needed to run this.

Thinking about going back to 5.0.5 until this is fixed.
And through that I see how big of a help this button is. Meaning: Thank you Local team for making it that easy to manage my database. Yes, it is broken in this Subversion but in functional state this is a really helpful and comfortable feature :slight_smile:

Same problem here. Also having trouble connecting via socket and Adminer borks as well. Going back to 5.0.5 for now.

+1 Same issues… I wasn’t able to get Sequel Pro to connect via socket either though. Maybe wrong settings, although I feel I tried every combo of, localhost, and ports 3306, 10020, etc…

I did manage to get adminer to connect, but it instantly exhuasts memory on import and crashes.

I’m rolling back to 5.0.5 in hopes that works.

Update: Rolling back to 5.0.5 fixed this for me…

Back to 5.0.5 and Sequel Pro nightly is working again :slight_smile:

Hope you can pull that implementation back in the next minor release :slight_smile:

Hey y’all, also jumping on this bandwagon for 5.0.6 and the Sequel Pro button not working. It didn’t seem to work with the version linked to download either. Also doing that 5.0.5 rollback thing works great!

Take a look here.

Same issue… The Local devs used to be quite active here but now a glaring issue doesn’t get any attention at all :confused:

Any updates on this? Would be nice to have someone provide an eta on getting this fixed as it’s a major issues. Especially since we’re being pushed to install Lightning instead of the older version. The main page now only provides the lightening download. Can someone from the Flywheel team update us please?


Same… 5.0.6 and 5.0.7 don’t work properly with Sequel Pro. I’ve rolled back and stayed with 5.0.5.

It’s a PITA but it is possible to manually put the socket information into Sequel Pro. @afragen detailed that here Access to Sequel Pro in 5.0 Beta(s)

Same issue here. 5.0.6+976 here. I don’t think I have Sequel Pro nightly either. Looks like Sequel Pro 1.1.2.

I tried @afragen’s method of adding the socket connection in Sequel Pro but got an error.

You need the nightly for Local 5.x as it’s using MySQL 8.x


I clicked the blue button to get the latest here https://sequelpro.com/test-builds, installed it, then restarted Local. I still see the Download Sequel Pro link, but now manually adding works. Thanks.

1 Like

Still using 5.0.5 because of this issue… Doesn’t appear that 5.0.7 addresses it either?

Fixed in Local 5.1.0

Thanks @afragen, can you tell me where I can get it? Updating from 5.0.5 only went to 5.0.6.xxx.
I downloaded a fresh copy from the main lbf.com, but it went to 5.0.7, and shows as up to date when checking for updates.