Local ran into EPERM error

Hi There;

Trying to resolve this issue with EPERM error. I checked the Read Only and that is fine.

I am running Kaspersky and the link you give re same is not clear enough. Here is a screen shot of my Kaspersky screen where I added Local by Flywheel as an exception.

Would love to hear more from you.

Eperm

Hey @ElodieG

EPERM issues are usually caused by Antivirus, so you are right to look at your Kaspersky settings.

I’m not sure what things to enable in order to get things to work. You might try checking “Do not monitor activity of application” as well as “Do not monitor activity of child applications”

This is because Local delegates a lot of what it does to other software like Virtualbox.

Give those settings a try and let us know how it goes! If you have any other questions, just let me know!

– Ben

Hey Ben:

Just a note to tell you your solution worked - I checked the above boxes - and website up and running! Thank you! EG

1 Like

Hi Gents,

I thought I’d just add that the solution above worked for me too. For anyone else that gets stuck, I had to go into Kaspersky then select, more tools, click on application control details, manage applications, then click the cog (settings) lower left of application control window, then click additional, then select threats and exclusions settings, then select ‘specify trusted applications’, then select ‘add’, then scroll down the list of applications in my case to the bottom of a very long list where I found the two flywheel applications and finally selected 'local by flywheel. At that point once added, i then selected the edit option and checked the two boxes ‘do not monitor application by activity’ and the ‘do not monitor the activity of child applications’, saved changes, etc… then on the flywheel application where it says fix the problem selected that, and click allow etc, and basically it then worked…

Hope this ramble helps someone, as it had me stuck for a few hours…

1 Like