Local Router Errors Again

Haven’t seen these in about a month; but now they’re back and I cannot work on my newest project >.<


Is this happening only on the one site or this happening on all sites?

If it’s happening on only the one site, then there may be a configuration error on the web server that’s keeping it from starting.

Only this one website currently; it was working yesterday though…

If the site is running nginx on the Custom environment (let me know if otherwise) I would try the following:

  1. Right-click on the site in the sidebar
  2. Go to “Open Site SSH”
  3. Run nginx -c /etc/nginx/wordpress/nginx.conf -s stop
  4. Run nginx -c /etc/nginx/wordpress/nginx.conf and see the what the output is

It is on nginx; how do I confirm if its set to custom environment?

I have a feeling its just the preferred setup since I will be migrating project to Flywheel once completed…

If it’s on Custom you won’t see “Dev Mode” in the top-right of the site info page.

Also, I would check the logs folder in that site’s folder for clues.

Okay I do see the dev thing toggle - http://d.pr/i/PKmf2B

here is ssh - http://d.pr/i/W151Qz

Thanks for the screenshots!

Considering it’s Preferred, can you try this command instead of the commands on #3 and #4?

nginx -s stop; nginx -g "daemon off;"

tried the command and there is no output: http://d.pr/i/tzsXGr

Interesting, can you try one more command and screenshot it?

ps aux

I exported site and re-imported it and it worked for like an hour; now its doing the same thing. Did that last screenshot help at all, desperate here >.<

I have been having to export then import sites for them to only work for an hour or so and then stop; is there PREMIUM support I can pay for to get this handled sooner then this slow support forum?

I ditched desktoptopserver and mamp pro for local and I’ve never been unable to work on projects with either…