Local Community

Local stuck on loading after startup

Issue Summary

I’ve been using Local for a few months now and never had any issue. However when I tried to open Local this morning it doesn’t startup correctly and gets stuck on loading. See image 1 below.

Image 1. - Screenshot of the issue

I can’t access any of my sites or the settings etc. and I’m on the latest version (6.7.1). And after reinstalling I run into the same issue. It gives me the option to accept the privacy policy. I check the box and agree. And I’m straight back into this loading screen.


Replication is a bit tricky since it happened from one day to the next. And I haven’t installed or changed any other software on my MacBook. I also haven’t encountered this issue on my other devices.

System Details

  • Which version of Local is being used?
    6.7.1. I tried both the macOS and the Apple Silicon version, same result.

  • What Operating System (OS) and OS version is being used?
    I’m running macOS 13.3.1

  • Attach the Local Log. See this Help Doc for instructions on how to do so:
    local-lightning.log (59.1 KB)

Hi @thijs

Are you running other developer applications simultaneously? That could also cause similar issues. Apps like MAMP, XAMPP, or Docker for example.

Can you drop a copy of your Local Log here as well? Retrieving Local’s Log File

Hey @Nick-B,

I’ve tested a few things but couldn’t resolve it. I tried using a similar application (DevKinsta) and got some weird errors too. They are probably related. I could create a site there but couldn’t access it and wasn’t able to delete the created dev site.

The issue has probably something to do with my MacOS install, something wasn’t working like it was supposed. I reinstalled my MacOS installation and Local works again.

Thanks for your response tho!


No problem! Glad to hear things started working again for you.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.