Local won't open my new site

What issue or error are you experiencing?

I’ve made a new website in Local. Its a simple landing page so nothing complicated. I cannot open the site in local or the other site that is there still. It says this

'our PHP installation appears to be missing the MySQL extension which is required by WordPress.

Please check that the mysqli PHP extension is installed and enabled.’

Previously it opened normally and worked well. I thought I’d change the name which I did and it stopped working, so I changed it back and it still won’t open. I am a beginner so please make explanations simple.

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

Have tried shutting down and reopening and opening a trail website i experimented with and that also won’t open whereas it did a few days ago. .


System Details

  • Local Version: Wordpress is latest version ending in 3.

  • Operating System (OS) and OS version: Windows 10 Firefox, but same in Edge and chrome.


Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)
http://fabfantasyphotos/local-xdebuginfo.php


Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @Kat1

There are some different ways to access and share Local Logs. For us to be able to troubleshoot thoroughly, please click the Download Local Logs button from the Support tab in Local. This will generate a zip archive that contains the Local log along with some other diagnostic information to help quickly zero in on any issues that Local is encountering.

Keep us posted and we’d be happy to help further!

Hi. Hopefully this helps sort out the problem
local-logs1.zip (291.8 KB)

Thank you for those! It looks like Local is having trouble running MySQL either due to another program or something like antivirus blocking the way.

Are you running other developer applications simultaneously? That could also cause similar issues. Apps like MAMP, XAMPP, or Docker for example.

Do you have any antivirus, security, or firewall applications that could be blocking Local?