Local Community

Local won't open on Mac OS Big Sur

Issue Summary

After Big Sur update, older version of Local wouldn’t open due to kernel extension error and virtual box (don’t know Local version number because I can’t get it open).

Troubleshooting Questions

I downloaded 5.9.2 and instead of replacing the current Local install, it added next to it (I must have been on a pretty old version of Local?). When I open the new version of Local (seems to work on Big Sur), none of my sites are there. Did the folder structure change? How can I direct the new Local to the sites that were created with an older version?

System Details

  • Local 5.9.2

  • What Operating System (OS) and OS version is being used?

    • MacOS Big Sur 11.0.1

Thanks!

Hi @btetrault,

If I’m not mistaken the previous version of Local which uses Virtual Box is no longer being worked on. It would have been possible to export your sites from the old Local and import them to the new one before you updated to the new macOS.

With the new Local development there is no connection to the old one meaning you would have to manually transfer the site through Export/Import methods. As you mentioned the old version is not working on the new macOS so my only suggestion is to create the sites again in the new Local and manually import your old SQL database files and wp-content folders for each site. That is if you still have them accessible on your HDD.

I hope some of this helps you.

Does this mean that the most recent version of Local is working on Big Sur?

Hi @lukenetti3,

Yes the current version 5.9.2+5056 is working on macOS Big Sur.

You aren’t alone! I did not know there was an update. Experience breakdown.

Oh well in my case I can start again as most sites had been deployed and were redundant. Should I stick with local or is there a better alternative?

Hi @HammerOZ,

I personally think both the old Local (w/ Virtual Box) and new Local (Lightning) was/is a great local development system. There are alternatives out there though… Depending on your OS (MAMP, XAMP, WAMP) you have selection. I’ve used all of these and to be honest found the user experience subpar. I’ve also gone terminal/console based and used to use Vagrant coupled with Virtual Box which would constantly crash and would generally spend more time fixing the environment than actual work. The new Local also doesn’t require Virtual Box anymore and is super fast, very easy to use, and best of all the free version has pretty much everything you could need. I highly suggest sticking around!

2 Likes

Any ideas how I can import the DB from the old Local to the new Local?

Hi @btetrault,

The following steps should help you move the sites manually to the new Local.

  1. Download and install the new Local to your applications folder (it should not overwrite the old version as they are 2 different applications)
  2. Point your new Local default site path to a different folder than your old Local (if you want the new Local to use the same site path as before you will need to move all of your old site directories to a different folder)
  3. Create a site with the exact same Site Name as before
  4. Once created copy your wp-content folder from the old site directory to the new one
  5. Open either Adminer or Sequel Pro delete the tables of the new site and import the SQL files from your old site (the SQL files can be found in the following folders app > sql)
  6. Repeat steps 3 - 5 for each site you want to port

Once you’ve done this for each site you should be good to go with the new Local.

One recommendation for the future. Make sure to export site data before upgrading the OS and you’ll be set for a quick import.

2 Likes

Hi @matthewfarlymn,

Thank you very much for your assistance with this. I’m in the same boat as @btetrault. I updated my OS to Big Sur yesterday and getting the same error from local by flywheel. I followed your step-by-step instructions on moving the site manually to the new local.

I think I did something wrong and if you could help it would be greatly appreciated.

I followed steps 1 to 4 per your instructions. For step 5, I opened Adminer but didn’t see an option to delete the tables, so I left it as is.

I then proceeded to copy the contents of the folder app > sql from the original site’s folder and pasted it in the new site’s app > sql folder.

I don’t see any of the pages I made from my original made on previous local by flywheel.

Your helps is greatly appreciated.

Thanks in advance!

A post was merged into an existing topic: Latest update broke PHP 7.4.1

Hi @AyKay647,

It will not work to just copy the SQL files into the news sites SQL folder. What you will need to do in Adminer is the following:

  1. Select all tables using the checkboxes located to the left of each line when in Tables and views
  2. Once all tables have been selected you can than use the Drop option which should remove them from your DB.
  3. Once all tables are removed you will select the Import option in the left sidebar and import all of the SQL files from your old site.

As long as the new site created naming matches your old site everything should be working. If you have altered the name of your site you will need to update the wp_options table to match your new site address.

Hope this clarifies things for you.

Hi @matthewfarlymn Thank you for the detailed explanation.

For step 3 in your instructions to import the SQL files from the old site – in adminer it only gives the option to import sql [.gz] file. When importing the sql file from the folder app > sql in the old site’s directory, it gives an error.

Any suggestions?

Hi @AyKay647,

My recommendation than would be to use Sequel Pro (Test Build). It’s much easier than Adminer and the Test Build version works with Local.

Hello,

Same issue for me. I followed all your explanations. Everything works fine until importing the database.

First tried to import with Adminer and I have the same error than @AyKay647. (Unknown error 1146)

I Downloaded Sequel Pro and tried to import all the files => same result, some files cannot be imported ([ERROR in query 4] Unknown error 1146).

Thanks for your help!

Hi @juliencakktus,

Could you try importing 1 file at a time to determine which file is having the issue?

In general, if you can open Local Classic (v3.3.0 and below) then this help doc should help with migrating to Local Lightning (v5.x)

https://localwp.com/help-docs/getting-started/migrating-from-local-by-flywheel-to-local-lightning/

Since most of you are having issues with Local Classic not opening, then the steps that @matthewfarlymn is recommending are a great way to manually migrate the site when you can’t open Local Classic.

One alternative approach is outlined in the “Restoring From Only Local Site files” section of this help doc:

This basically outlines creating a new zip file with only the wp-content folder along with the .sql file for the site and then dragging and dropping that zip onto Local Lightning.

@AyKay647 @juliencakktus @btetrault – can you give that workflow a shot and see if that gets the sites migrated to Local Lightning?

1 Like

Hello,

It works for me with “the restoring from only local site files” method.

Thanks!

2 Likes

@ben.turner that is brilliant. I didn’t realize that this had been implemented! Sooo simple.

1 Like

Zipping the entire folder from the old Local and then dropping it into the new lightning Local seemed to have worked like a charm for this first site I’m working with. Was also quite large: .zip was 2GB+ and the import took less than a couple of minutes.

The big question for me now will be to see I can get our Github deployment connection back to working properly again as that’s our primary way of making and pushing changes to our production site. Will post an update about that once I get a chance to play more.

Thanks @ben.turner for the tip!

1 Like

UPDATE: the Github connection worked perfectly. We are back up and running 100%.

1 Like