"Checking System"

I’m on a MAC (Big Sur). Have Local by Flywheel 3.3 installed. Have used LBF for a few years but for some reason for the last couple of days, am unable to open the application. It is stuck on the screen “Checking System.” Can you help?

local-by-flywheel.log (62.7 KB)

It appears no one is going to help here. So I have another question.

How does one go about exporting from LBF 3.3 so I can IMPORT to the newest version of Local. Local works fine on my machine. But all of my sites are on Local by Flywheel. So it looks like I’m totally screwed. For grins I tried reinstalling LBF on my computer since it appears VirtualBox is no longer installed. With the failed attempt I found out why; trying to install 3.3 throws an error that never resolves itself. It seems there are components in VirtualBox that are no longer compatible with my Mac OS. So again…

How does one EXPORT from LBF without actually being able to open it so I can import into the newest version. Is there any hope in recovering these websites I’ve worked so hard on??

Hey @kerry – Big Sur did break Virtual Box which is what Local Classic used to manage the WordPress sites.

This help doc outlines the general process of migrating from Classic to the newer version of Local:

But since you mention having issues opening Local Classic, you might have to manually restore the sites using the files that are on the machine.

You can do this by following the steps outlined in the “Restoring From Only Local Site files” section of this help doc:

Thank you for responding. This worked but I’m seeing two problems right away. Do you know why the URL has “?cache-buster” and some numbers appended to the end? I never saw that in the classic Local version.

Also, it may be because I’m using a pagebuilder (Elementor). But it seems that background images don’t actually load on the imported site. I found that if I go into the Elementor editor, click on the section and reselect the image, it loads. But it doesn’t load automatically without doing that. Other images (placed images) seem to be fine. It’s only the background images. I saw this on the two sites I imported.

This is to help with breaking the cache and is something that Local will add when clicking the “View Site” button. You can safely navigate directly to the Local site from within the browser.

Has the URL changed between the two sites? You might take a look at Elementor’s settings within the WP Admin. There’s an option called “Regenerate CSS” which will re-export the URL that’s set within the DB into the actual styles that are in the CSS files:

This is a similar issue if you ever need to take the site live and need to change the URL from Local to Production.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.