Local's router having trouble starting

Hello !

the title describes my issue… I really could use some help…

Thank you in advance to all!

Hi There,

Not sure if this helps you, but I had a similar issue on macOS Mojave after install. In a nutshell, I had a couple of permissions issues.

First, I had to fix permissions on the “/Users/[username]/Library/Application Support/Local/run/router/nginx/logs” folder. Not having write access was preventing nginx from starting (I saw this error in the local lightning log file).

Second, once I fixed the above issue and I got the site to start/load, I was having weird issues updating pages. I use Divi for development and when I would try and update a page it would launch a separate “preview” tab (and not save the changes). I fixed this by fixing the permission on the “/Users/[username]/Library/Application Support/Local/run/router/nginx/client_body_temp/” folder. For this second permission update, I had to use terminal/sudo-commands to fix the permissions.

Both log files (the router log and the main lightning log) were really helpful in tracking these down. I hope this helps.


Hi John,

Thanks for the reply. I’m having the same issue due to updating to Catalina.

I’m afraid I’m not following your instructions. I tried to track down that folder that you mention, however I don’t have a “Library” folder in the file path you stated. I can get as far as “/Users/[username]/" and after that, no “Library” folder. Any ideas why that might be?

Also, how do I change permissions once I get to the correct location?


From the Finder, go to Go menu. Near the bottom is a Go to Folder menu. Use that.

Thank you afragen. I tried that, but that path does not seem to exist.

Put /Users/[username]/Library in that menu search box. A shortcut might be ~/Library

You must understand, I can tell you with 100% certainly that you have at least 2 Library folders. One for the root directory at /Library and one at /Users/[username]/Library. Your Mac would not function without them.

Hi afragen,

Thanks! I made a mistake when I copied over the path and that was my problem. When I correctly pasted the path in, it went right to the correct folder.

I opened “error.log.” and did not see any errors dated yesterday (12/22/19) and today (12/23/19), which is when I ran into the problem.

In johncolemans previous post, he discussed changing/correcting permissions. How do one do that? I’m not sure how to even determine/figure out what current permissions are or where to find that user interface to figure that out.

Folder and file permissions can be changed in the Finder by selecting the item an using Ctrl - I, or selecting Get Info from the Finder menu when that time is selected.

Thanks, afragen. I did find the Permissions drop down by using the “Get Info” link in the Finder Menu. I missed it at first as it was all the way to the bottom of the dialog box for me.

I had to click on the paddle lock icon in the lower right of that dialog box to allow changes to be made.

“System” was already set to “Read and Write.” “staff” and “everyone” was set to “Read Only.” So, I changed both of those to “Read and Write.” That solved the issue.

I appreciate the help!

1 Like

Hi Curt,

Glad you got to where you needed to go (thanks to afragen’s help, of course).

Running down these permissions issues in the log file(s) was definitely the difference-maker for me and I’m glad you got things sorted.

For anyone else reading this, you can access the log files from within Local by going under “Help” in the top menu.


Any permissions issues should be pretty obvious. If I remember correctly, the permissions issues I had were in the “Local’s Log” (vs people who have issues with ports being used for other processes figured this out from the “Local Router’s Log”). Any error with verbiage like “could not open” “permission denied” etc. point to a file/directory permissions issue. And for Local to run, the user running the process has to have rights to whatever files/folders it is trying to write to.

From my reading anyway, it seems that these are two of the biggest issues with getting Local to start (either file/folder permissions or trying to use a port that is already in use by another process).

1 Like

I have answered this issue -->> HERE <<–. There are 2 workarounds that I’ve tested they both worked for me. Let me know if it works for you too.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.