Error Router


i’m a new user of Local by flywheel.
If i want to start this program i get error: ‘Heads up locals router is having trouble starting, View the router file for more details’.

Is there anything i can do to fix these error?

Greetings Bjorn

Hi Bjorn,
I am having the same issue after I updated Mac OS. Did you ever figure this out?

Hi Maggie,

No, i dont figure this out yet.


I have the same problem. Heads-up! message. I tried so many things and disabled all the security settings. Mine is an iMac OS Majove V.10.14.6.
I attached the log file. I would really appreciate if anybody could help me.

Best wishes

local-lightning.log (43.6 KB)

Hello again,

I have just solved the problem. This may help others too. In the log file which I attached above, there was a line:
Library/Application Support/Local/run/router/nginx/logs/error.log" failed (13: Permission denied)
I located that error.log file. Right click the file, Get info, when the file info box opens, go down to Sharing & Permissions, change the Privilege from Read Only to Read & Write.
That’s it.


Is this only for mac or is it for windows too?
Cause i can’t find the error log file.

This is for mac. Open Finder. Click “Go” tab. When you press ‘option’ key on the keyboard, you’ll see ‘Library’ appears. Choose Library and follow the path on the previous post.

I don’t have mac.

But thanks for helping

Hey everyone!

I just encountered this after finally upgrading to MacOS Catalina and thought I would share the solution.


When you open Local and try to start a site, you’ll likely see a banner across the top indicating that Local's router is having trouble starting.

If you examine the local (which you can find by following the steps in this forum post:
How do I retrieve Local's log file? - FAQ - Local Community ) – You’ll see errors that look something like this:

2020/03/19 09:26:58 [emerg] 22206#0: open() \"/Users/benjamin/Library/Application Support/Local/run/router/nginx/logs/error.log\" failed (13: Permission denied)

Fix (MacOS)

If you navigate to where the error points you, you’ll likely notice that the permissions have somehow changed so that root owns the error.log file. The fix is to change the ownership of that file and then click the “Retry” button within Local.

I did this using a terminal and this command:

cd ~/Library/Application\ Support/Local/run/router/nginx/logs
sudo chown <your-computer-username> error.log

Once that ownership has changed, click the “Retry” button within Local to start the router.

Fix (Windows)

I haven’t reproduced this in Windows, but I imagine the steps would be similar. To summarize:

  • Navigate to where Local stores the router configuration.
  • Update the ownership or permissions of the error.log file so that they are more permissive
1 Like