LocalWP doesnt let me log in to WP admin

Issue Summary

Like the title says, when i press the login button on my WP admin page it just refreshes the page.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?

It happens to a site i migrated from DevKinsta and to the fresh test side i spun up on Local.

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?

No

Replication

System Details

  • Which version of Local is being used?

7.0.1+6387

  • What Operating System (OS) and OS version is being used?

Windows 10 Professional

local-logs.zip (4.9 KB)

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

3 Likes

interesting. same problem I have.

  • is this the only site you have?
  • do your sites load at all or do you get a 404?
  • where is Local installed and what are the paths of the sites?
1 Like

Oke so if i create a fresh install, the same problem occurs.
If i just try to visit the site it’s it loads up fine.

The paths are:

C:\Users\henkf\AppData\Local\Programs\Local

and

C:\Users\henkf\Local Sites\dutchscape

1 Like

Hi @HKFolkertsma

  • Are you using NGINX or Apache for server type?

  • What is your Router Mode set to?

  • Does it happen in a different type of Browser? Chrome, Safari, etc

Hi ! I was having the same issue with a newly created site. It seems that the generated wp-config.php file was having an issue : reorganizing it fixed the problem. Salt keys where put at the wrong place. Move them just after the db configuration, and put line “/* That’s all, stop editing! Happy publishing. */” on the very bottom of the file.

12 Likes

Hey @Nick-B
I am using NGINX.
Router mode is set to Site domains.
Yes it does, i tried Firefox, Chrome and Edge (also on private tabs)

I tried moving around what i thought you meant.
But that gave me a datebase error.
Could you explain it in a little more detail?

omg! seems this solves it for me

login just worked afterwards. but what the heck :joy:

3 Likes

There were a couple of specific changes around wp-config.php not in the latest release but in release 6.7.2. Would these have caused a conflict with your set up?

WP_ENVIRONMENT_TYPE has been moved to the wp-config.php file and set to local for all newly created sites. Previously, this value lived in the local-bootstrap.php file. This should make the environment type easier to change programmatically. See this feature request: Don’t define WP_ENVIRONMENT_TYPE
Salts are auto-generated in the wp-config.php file on site creation again; all newly created sites will see these values defined in the config file again. See this bug report: Lack of Salt Secret-Keys in new installations

If i change my wp-config.php in the same way you did like this:

<?php
/**
 * The base configuration for WordPress
 *
 * The wp-config.php creation script uses this file during the installation.
 * You don't have to use the web site, you can copy this file to "wp-config.php"
 * and fill in the values.
 *
 * This file contains the following configurations:
 *
 * * Database settings
 * * Secret keys
 * * Database table prefix
 * * Localized language
 * * ABSPATH
 *
 * @link https://wordpress.org/support/article/editing-wp-config-php/
 *
 * @package WordPress
 */

// ** Database settings - You can get this info from your web host ** //
/** The name of the database for WordPress */
define( 'DB_NAME', 'local' );

/** Database username */
define( 'DB_USER', 'root' );

/** Database password */
define( 'DB_PASSWORD', 'root' );

/** Database hostname */
define( 'DB_HOST', 'localhost' );

/** Database charset to use in creating database tables. */
define( 'DB_CHARSET', 'utf8' );

/** The database collate type. Don't change this if in doubt. */
define( 'DB_COLLATE', '' );

/**#@+
 * Authentication unique keys and salts.
 *
 * Change these to different unique phrases! You can generate these using
 * the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}.
 *
 * You can change these at any point in time to invalidate all existing cookies.
 * This will force all users to have to log in again.
 *
 * @since 2.6.0
 */


/**#@-*/

/**
 * WordPress database table prefix.
 *
 * You can have multiple installations in one database if you give each
 * a unique prefix. Only numbers, letters, and underscores please!
 */
$table_prefix = 'wp_';


/* Add any custom values between this line and the "stop editing" line. */

define('AUTH_KEY',         'jB8Te6OQDnFLom1HMKuLnswdAuPZRmD5nO0BWW1HmHi5W4fj8Tj1uheXfPr0srtdP9zTjX5xRva4sjAwph2SYA==');
define('SECURE_AUTH_KEY',  'vI6TxGbvedvpgj8JgUEN1UPuw/sGeZVhatP7wa9xGCm7590mTmYEWxP5bUAGofzvizumB90YWHgFYXOFLG/Ilg==');
define('LOGGED_IN_KEY',    'rL97I2hrsGpr68LczScvtvr4BIWKhwUvDTqHt1cs1eAkjnuSofM2Zakz3uCN/V7riW+k7x/1oNZPt5QihABk2Q==');
define('NONCE_KEY',        'IuziJlVZLF6aoRTIN1ZJhMjOuSrYLy243OFR0op7OxiilOoDmjs7yzvbpAGXZPVngg0KpkFnEtKaxbteQddTTw==');
define('AUTH_SALT',        'vz8YFvYvOaEm9X0tCFeB0PjvYo9trpMj5orTdiGZwV6oec4nab2fb8YgogXntsE3k3w7JhXAM04t7bu9SVsd3g==');
define('SECURE_AUTH_SALT', 'OOwbz4b7alV4+lsKUZjbHkFXTu+CZqUPL4nMwVIGFC2F1UHiQT6LQsNXJxvKsD7P4iHI9vC8duoF/WoAAar/0g==');
define('LOGGED_IN_SALT',   'qR+/mUT5kQJKRldqWKHGkCVpkLpMLVF/XMyYMLLaO6vRYxWxob+dTKbiRbobvpe/Ndxj8uLxi0UbNHLzmwgi9w==');
define('NONCE_SALT',       'H7hT+xqTyWoOv26aJ69Y+hCxCn/3VogAAIEeNOkMnE6koZs92uuhG/qtAqjOsTj0UvZQAU6JGwh+niKesbexXw==')

/**
 * For developers: WordPress debugging mode.
 *
 * Change this to true to enable the display of notices during development.
 * It is strongly recommended that plugin and theme developers use WP_DEBUG
 * in their development environments.
 *
 * For information on other constants that can be used for debugging,
 * visit the documentation.
 *
 * @link https://wordpress.org/support/article/debugging-in-wordpress/
 */
if ( ! defined( 'WP_DEBUG' ) ) {
	define( 'WP_DEBUG', false );
}

define( 'WP_ENVIRONMENT_TYPE', 'local' );
/* That's all, stop editing! Happy publishing. */

/** Absolute path to the WordPress directory. */
if ( ! defined( 'ABSPATH' ) ) {
	define( 'ABSPATH', __DIR__ . '/' );
}

/** Sets up WordPress vars and included files. */
require_once ABSPATH . 'wp-settings.php';

;

When i open WP admin i get this error :


Am i missing something?

a semicolon at the last define() ? not sure :smiley:

O M G i am stupid…

; added

IM IN! Thank you all so much!

2 Likes

Thank you so much for this solution and to @prototowb screenshot make it clear.

2 Likes

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.