Mailhog not catching mails on Windows

Hi, I recently installed a third site I’m working on with local. Mailhog is not catching emails and I don’t know why.

  • I have no email plugin that could affect default settings
  • My other sites are catching email just fine, same OS, same browsers, same computer.
  • SSL certificate is trusted
  • Tried changing site domain
  • Stopped site and restarted a few times
  • Restarted computer

Is there a setting I could do? where can I check if there are issues?

1 Like

I have the same problem. But worst, because since I instaled Local on my windows PC I could never recibe any emails in mailhog.

I have looked up for help in many sites (including support questions at but I can´t find how to fix it!!

Any help will be welcome.

Thanks, Martín

Hi all,

Sorry for the trouble with MailHog!

Are you both able to open up MailHog on the sites where it’s failing to catch the e-mail?


What operating system are you using?

1 Like

Hi @clay

I am able to open MailHog. I have 3 sites on local and the other two are working just fine.

OS is Windows 10 home 64bit x64 version 1903 build 18362.778.

I reinstalled latest local version today also, no luck.

Any troubleshooting tips I could use? I am building a marketplace and cant test vendor accounts bc of this.


Hi @clay thank you for your help!

I am able to open up MailHog from Local utilities, it opens fine but it never receives any email!

I have tried creating new local sites with different configurations and check if I receive any email, no luck with any of them.

I also reinstalled Local today, no luck either.

I have the exact same problem than Maurolocal, I am building a marketplace and I don´t recieive vendors emails. As I thought It may be a woocommerce / vendors or wp configuration problem I have tried logging out and choosing “forget your password” from the singing in wp-admin site, to check if I recieve an mail from that action, no luck either.

My system is Windows home 10, Version 10.0.18362 Build 18362 x64

Thanks again, Martín


I’m unable to open Mailhog at all.

Today I wanted to test emails, but I can’t open it by clicking on “Utilities -> Open Mailhog”. Unfortunately, I don’t know which update caused this bug, as I haven’t used Mailhog for a while.

Thank you.

Thanks for the details @MartinJ!

@Craager @MartinJ @maurolocal,

If MailHog is opening but not receiving e-mail, it sounds like it may not have an SMTP port allocated.

Can you all please provide your local-lightning.log file? See for instructions on how to do so.

Thanks for your patience regarding this! We’re eager to figure out exactly what’s happening.

1 Like

Hey @clay thank you for getting back to us. Here’s my log file.

local-lightning.log (293.1 KB)

1 Like

Thank you! Here goes mine.
local-lightning.log (94.0 KB)


1 Like

Hey all,

We were able to reproduce this issue on Windows on our end.

Thanks for all of the logs and details!

1 Like

I think my problem is different, I’m just can’t open Mailhog. Attached logs

local-lightning.log (324.7 KB)

This is a regression in Local 5.4.2 that will be resolved this week. In the meantime, you can downgrade to 5.4.1 and it should take care of the issue!

Regarding MailHog not intercepting e-mail on Windows, we’ve tracked this down to a config regression in a recent fix.

To work around this issue, you can:

  1. Open up your site’s conf/php/php.ini.hbs file (conf is adjacent to the site’s app directory)
  2. Change
    sendmail_path = "'{{mail.mailhogPath}}' sendmail --smtp-addr={{mail.mailhogSmtpAddr}} mailhog@flywheel.local"
    sendmail_path = '"{{mail.mailhogPath}}" sendmail --smtp-addr={{mail.mailhogSmtpAddr}} mailhog@flywheel.local'
  3. Restart the site

Please note, we’re going to be improving testing around functionality like MailHog in the near future to help catch potential regressions like these in the future.

Sorry for the trouble!


Hello @Clay. Thanks for letting us know, glad to help.
How can we resolve the issue now that you are able to reproduce?
I need to get it working in order to move fwd with my project.

Just saw your posting on top of mine with a workaround. Will try and let you know if it works.


Hello there,

On my end the issue is resolved apparently. All mails are being catched by mailHog.

Thank you for helping!

1 Like

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.

Hi all,

If you are running into this issue or use the workaround, be sure to vote up for tracking’s sake!

Hi @Clay it worked out fine! Thanks a lot!!
Sorry for the late answer!

This continues to be an issue as of 5.5.3 - although the workaround does continue to work. Note that the difference in workaround is the order/type of quote wrapping rather than changes in parameters.