Local Community

Max_execution_time

Issue Summary

I can’t upload file for more than 30 seconds. I’ve set max_execution_time to 0 and to 10000 but it won’t help. I’ve set other settings such as upload_max_filesize, post_max_size, memory_limit, max_execution_time, max_input_time accordingly. But it didn’t work. Does Local itself limits the upload time? Any advice on how to fix it? Thanks!

Troubleshooting Questions

  • Any advice on how to fix it? Thanks!

Replication

Try to upload 90GB file on your WP website using All-in-one-migration plugin

System Details

  • Which version of Local is being used?
    6.5.2

  • What Operating System (OS) and OS version is being used?

    • _For example: macOS Big Sur 11.4
  • Attach the Local Log. See this Help Doc for instructions on how to do so:

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

@Michael9

After adjusting the timeouts and resources are you stopping the site and restarting it? That’s a necessary step for Local to compile and use those new settings.

That being said, 90 GB is quite the file size. Is there anything that can be parsed out to bring the total size down? Like does it have lots of media?

@Nick-B
Yes, Nick, I’ve restarted local, and made sure that the new PHP settings applied. However it still goes off after 30 sec. I removed some files, made it 20GB, but it’s still not enough…