Maximum upload file size

How do I change the Maximum upload file size in Local? It is now set to 300MB but I want to import a site from backup that is 399MB.

1 Like

Hi @lvpapa,

You can change the upload limit from the php.ini file for your Local site.

To do this, navigate to Local Sites/your-site-name/conf/php/php.ini

Open the php.ini file in a text editor, and search for the line for upload_max_filesize. You’ll want to change the default value from 300M to your desired value, and then save the file and restart your Local site.



Thank you very much for your assistance. Unfortunately, I can’t find the path you refer to. On a windows computer, I go to users/local-sites/ and I find a folder labeled with my site name. Under the site name folder, I find two folders app and logs. Under app I find folders public and sql. Under public I find the entire wp files with folders for wp-admin, wp-content and wp-includes.

I do not find conf/php/php.ini anywhere in any of these folders. Can you help me with this again, please?

If you’re using Local 3.x you need to be on a custom environment. Then there will be a conf folder at same level as app.

If using Local 5.x, the above applies as well.

All this is if memory serves as I’m not at a computer. :upside_down_face:

My site is limited to 1 MB file size upload. I’ve changed the value in conf/php/php.ini.hbs (can’t find conf/php/php.ini) and nothing changes. I’m a complete nubie to this. What does the .hbs extension mean. Is there some other place I should look to get this limitation increased?

Dave :-}>

OK. I found the max upload file size adjustment in Network Admin Settings.

where did you find the “Network Admin Settings”?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.