Multisite Migration from live to local

How Can I migrate my multisite website from Live flywheel to local? I wanna test my website content to see if it is php 7 ready…

I tried import the backup files… but the website turns out to be not multisite… I checked advanced options but no option for multisite… except when creating from fresh one…

1 Like

bump still waiting

Hi @termerstan,

Importing sites that are configured to use WP multisite does take a few extra steps. Here’s what you can do:

  1. Create a brand new site with multisite enabled
  2. Copy in the wp-content folder from the Flywheel backup
  3. Drop all of the tables in the database for this new site
  4. Import the database in the Flywheel backup using Sequel Pro, Adminer, or WP-CLI
  5. Then, using WP-CLI you can do a find and replace to update the domain

To use WP-CLI, right-click on the site in the sidebar then go to “Open Site SSH”.

Importing a database file using WP-CLI:

  1. Copy the SQL file into the site’s /app directory
  2. Run wp db import /app/SQLFILE.sql (update SQLFILE to match the SQL file name)

Updating the site domain using WP-CLI:

Example from

wp search-replace --url= '' '' --recurse-objects --network --skip-columns=guid
1 Like

Hello, I have been successful in recreating all your steps until the “Updating the site domain using WP-CLI” - I get an error of not found.

When I open the site from the “view site” button, I get “Error establishing a database connection.” And when I open the “Admin” section, I get a big database error (see “database-error.png”)

The only thing I think of is how in “Adminer” my tables have random numbers in between. Instead of wp_site, I have something like wp_lkjkf3f23f2_site. Do you say that makes a difference? Also, when do you think the “Flywheel connection” will be released?

One last thing to consider is that my site has an SSL installed - I’m not sure if that makes a difference either. I did try it with https as well and get the same error.

Hi @clay, is there any ETA for this version to be released? I’m having troubles importing multisite to local manually.


I imported a live multi site into local and the problem I’m having even after clicking sync hosts files near subdomains is that it is redirecting to the live site. I can’t access the frontend or backend of the primary site or any other subdomain site.

I have check the database and see the home and site url of the primary sites as the
I have manually changed the domains in the host file to

Nothing has worked. Any tips/help will be appreciated.

HI. Can someone point me to a more current thread that has a definitive answer for this? I urgently need to migrate two Multisites to my Local