Multisite with Domain Mapping

Has anyone successfully tested domain mapping with a local copy of WP Multisite? I have the multisite running fine with subdomains, but when I try to change the subsite’s settings to be a custom domain and then add that to my hosts file, it doesn’t work. I get the “Local Router Error” message. I’ve tried restarting the Local machine to no avail.


Hi there,

Right now we don’t support domain mapping in multisite but it’s definitely something we’re considering!

For the time being, I think the best solution is to enable domain mapping as soon as you push the site to your staging or live environment.

Understood, thanks.

This is too bad, I’m starting to like Flywheel but these kind of things keep making me go back to VVV

1 Like

Hi, Clay. Are there any developments in this area?

I tried to add a to my hosts file, and then I modified the site.conf nginx file to include that domain in the server_name directive as well, but even after all that I’m still getting “Local Router Error”.

Is there anything else I have to do to make nginx recognize that custom domain as well?

Thanks in advance.


+1 for domain mapping!

I also ran into the local router error with custom domains in multisite.

Would be great if Local will support this in near future!

Best Regards,

1 Like

local router error - need domain mapping - thanks

@sbgd @aanduque @steffen and @sunny I had a similar issue, though with multi networks, but I imagine the same (or similar) fix could help you work around the inability to add a domain. See the steps in my post here -, and consider/try it. I imagine it would likely work for you as well.

it worked for me after manually updating the hosts file, but a problem is, that LOCAL automagigally removes the added entry when it’s within the ##Local by Flywheel – Start / End comments

Entering the subdomain in the hosts file outside the LOCAL comments solves this

Used LOCAL version 2.1.1 on macOS High Sierra (Version 10.13.1) with “Faster Docker Volumes” turned off

1 Like

I really need to get Multisite running with domain mapping. I have client projects to update. Running a Mac OS 10.15.6

Prior to using Local, I did everything manually and it worked great. I’m trying to go back to that only for my Multisite websites while leaving all my non-Multisite installs running through Local. Trouble is, I can’t get it to work.

I’ve installed MySql 8.0.21

I’ve edited the /etc/apache2/extra/httpd-vhosts.conf with the location of the Multisite installs like so:

<VirtualHost *:443>
    DocumentRoot "/Users/XXX/Sites/XXX/web"
    SSLEngine on
    SSLCertificateFile "/Users/XXX/Sites/XXX/ssl/"
    SSLCertificateKeyFile "/Users/XXX/Sites/XXX/ssl/"

I’ve added the SSL certificate to Keychain Access

I’ve added the domains to /etc/hosts like so

## Custom Hosts - Start ##

## Custom Hosts - End ##

I have the database for the Multisite installed.

When Local is open, going to any of the Multisite domains loads up the Local site connection error screen. When Local isn’t open, I get “domain refused to connect” errors in Chrome.

With Local not running, I’ve checked / restarted Apache by running sudo apachectl -k restart

Anyone manage local Multisite installs not using Local as well as non-Multisite installs using Local? I’m sure there are people here who have to develop Multisite on a local machine. This is killing me it’s so hard!

+1 for domain mapping support

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.